summaryrefslogtreecommitdiff
path: root/dev-python/makefun
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/makefun')
-rw-r--r--dev-python/makefun/Manifest5
-rw-r--r--dev-python/makefun/files/makefun-1.15.2-test.patch98
-rw-r--r--dev-python/makefun/makefun-1.15.4.ebuild (renamed from dev-python/makefun/makefun-1.15.2.ebuild)12
3 files changed, 2 insertions, 113 deletions
diff --git a/dev-python/makefun/Manifest b/dev-python/makefun/Manifest
index d672d10f949b..a0255a41b2cf 100644
--- a/dev-python/makefun/Manifest
+++ b/dev-python/makefun/Manifest
@@ -1,4 +1,3 @@
-AUX makefun-1.15.2-test.patch 2871 BLAKE2B b36b8e8e40ab126e6875625a6584ae3eb78237203d426b3d2e7650c30c96e213d46c24980936d56868686fbdde93526e28d5a8b3f41330a2e398c00228097d34 SHA512 0a41884ac53c0efbbcf668aebf8119c096bddea6fe1a2ce66efc5a020d2bb3e4ce5a1cf2e02d7e4d65adfae8c45252e395f7458f5eb331adc618aa0407050bdd
-DIST makefun-1.15.2.tar.gz 74602 BLAKE2B 1992eebfdbff6062ed60e1f66891995a91b7155792ef7b6e701d1d3ee5939ab40d3ab976674e25a5b97030cd7de59db2c69f3c215681cef2f80f2b64523f822b SHA512 b6cb588ebf491176b06e97201846b2a5cee65f60e34b5dbcc4878d8a55e7f9fcf4b58126cb3a4ca47f5d2726422dff9ee685566c5d093dbd8fd75119ecc796b2
-EBUILD makefun-1.15.2.ebuild 774 BLAKE2B ac501bbadc947f37a39138bf0f27d8958e20d16346e530f944ec098ee767995daa5fd14b06590c919999bdfe7b1d7a8129dcecef5e43a8461ef6301e2b0fe014 SHA512 0749c2d29d4e5f023c9e6527a7d8fac38d5dcc0674e65470b91fad4bf5d497f854e695e9a950c8e69474740fde495e721eb9778ca6956a2e9343cd9fe5560dad
+DIST makefun-1.15.4.tar.gz 72160 BLAKE2B 361e598bf17c3e235934d65de48e638897dae9f93285269c39d97d1202506dd7e0c688b628d1811571fc259c39dbe345e8b269809c5079bf651a9ef09b681331 SHA512 eb6ed268137726ed306c7b118307ada365832d6f17a50da2804cc55708d114ad7e630ed4fdbd15a411d92ce601c4cc10d671d1ade7e270349009c10fd82618d7
+EBUILD makefun-1.15.4.ebuild 520 BLAKE2B f9fa6923f159d6e51c10dbb0287decf0289060bc2eaab3cad954ea8cf570b9d1ab35eb2037a750423839f9a20db4b90b567fefbe1e15224befad8a5e59bbbcfc SHA512 beb1a09674b26c0f1226cd49739fea5d05d8a2521c077cf08f9743923f3d6366cb4db81f4d23b9a2b9f49a585264b5e167a08c827b00c3a97213d5bbb69d6d07
MISC metadata.xml 396 BLAKE2B 541c5e69fc3236d1aaf79505272c9bdf2a295524bb9bb04e782a4cd15c022e74651a9c4ebaa244672418e5fafaed97a48568538fcd527b135c279576f09350d2 SHA512 a500a2a8b23673ea11ffdd81cae9c96fc1368121cd6ce7955fb61bc59319cf87607b134f6b5d04aa6aa564eab9c2c1248c47d0ccc624cdd8ae58f5f12d96e279
diff --git a/dev-python/makefun/files/makefun-1.15.2-test.patch b/dev-python/makefun/files/makefun-1.15.2-test.patch
deleted file mode 100644
index ab43045809d9..000000000000
--- a/dev-python/makefun/files/makefun-1.15.2-test.patch
+++ /dev/null
@@ -1,98 +0,0 @@
-diff --git a/tests/test_partial_and_macros.py b/tests/test_partial_and_macros.py
-index 6fd4503..3ce0a33 100644
---- a/tests/test_partial_and_macros.py
-+++ b/tests/test_partial_and_macros.py
-@@ -1,5 +1,6 @@
- import functools
- import pytest
-+import re
- import sys
-
- import makefun
-@@ -11,6 +12,11 @@ except ImportError:
-
- PY2 = sys.version_info < (3, )
-
-+# Python 3.13 dedents docstrings, earlier versions just strip initial
-+# whitespace. Use a regexp to get a consistently dedented docstring
-+# for comparison across Python versions.
-+DOCSTRING_NORMALIZE_RE = re.compile(r"^ +", re.MULTILINE)
-+
-
- def test_doc():
- def foo(x, y):
-@@ -41,15 +47,15 @@ def test_doc():
-
- sig_actual_call = ref_sig_str.replace("*, ", "")
-
-- assert bar.__doc__ \
-+ assert DOCSTRING_NORMALIZE_RE.sub("", bar.__doc__) \
- == """<This function is equivalent to 'foo%s', see original 'foo' doc below.>
-
-- a `foo` function
-+a `foo` function
-
-- :param x:
-- :param y:
-- :return:
-- """ % sig_actual_call
-+:param x:
-+:param y:
-+:return:
-+""" % sig_actual_call
-
-
- def test_partial():
-@@ -78,16 +84,16 @@ def test_partial():
-
- sig_actual_call = "(x, y='hello', a)" # if PY2 else "(x, *, y='hello', a)"
-
-- assert foo.__doc__.replace("=KW_ONLY_ARG!", "") \
-+ assert DOCSTRING_NORMALIZE_RE.sub("", foo.__doc__.replace("=KW_ONLY_ARG!", "")) \
- == """<This function is equivalent to 'foo%s', see original 'foo' doc below.>
-
-- a `foo` function
-+a `foo` function
-
-- :param x:
-- :param y:
-- :param a:
-- :return:
-- """ % sig_actual_call
-+:param x:
-+:param y:
-+:param a:
-+:return:
-+""" % sig_actual_call
-
-
- def test_issue_57():
-@@ -127,9 +133,7 @@ def test_create_with_partial():
- assert m() == -1
- assert m.i == 1
- # the doc remains untouched in create_function as opposed to wraps, this is normal
-- assert m.__doc__ == """partial(func, *args, **keywords) - new function with partial application
-- of the given arguments and keywords.
--"""
-+ assert m.__doc__ == functools.partial.__doc__
-
-
- def test_args_order_and_kind():
-@@ -161,11 +165,12 @@ def test_args_order_and_kind():
- # it is possible to keyword-partialize a positional-only argument...
- fp_ref = functools.partial(f, b=0)
-
-- # but 'signature' does not support it !
-- with pytest.raises(ValueError):
-- signature(fp_ref)
--
-- # assert str(signature(fp_ref)) == "(c, /, *, d, **e)"
-+ # but 'signature' does not support it before Python 3.12.4 !
-+ if sys.version_info < (3, 12, 4):
-+ with pytest.raises(ValueError):
-+ signature(fp_ref)
-+ else:
-+ assert str(signature(fp_ref)) == "(a, c, /, *, d, **e)"
-
- # so we do not support it
- with pytest.raises(NotImplementedError):
diff --git a/dev-python/makefun/makefun-1.15.2.ebuild b/dev-python/makefun/makefun-1.15.4.ebuild
index 29cd2d63889b..9778e4c78944 100644
--- a/dev-python/makefun/makefun-1.15.2.ebuild
+++ b/dev-python/makefun/makefun-1.15.4.ebuild
@@ -23,15 +23,3 @@ BDEPEND="
"
distutils_enable_tests pytest
-
-src_prepare() {
- local PATCHES=(
- # https://github.com/smarie/python-makefun/pull/103
- # https://github.com/smarie/python-makefun/pull/104
- "${FILESDIR}/${P}-test.patch"
- )
-
- distutils-r1_src_prepare
-
- sed -e '/pytest-runner/d' -i setup.cfg || die
-}