summaryrefslogtreecommitdiff
path: root/dev-python/m2crypto
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/m2crypto')
-rw-r--r--dev-python/m2crypto/Manifest4
-rw-r--r--dev-python/m2crypto/m2crypto-0.40.1.ebuild75
-rw-r--r--dev-python/m2crypto/m2crypto-0.41.0.ebuild2
3 files changed, 2 insertions, 79 deletions
diff --git a/dev-python/m2crypto/Manifest b/dev-python/m2crypto/Manifest
index 3cdc65cb09f7..68517225e5ed 100644
--- a/dev-python/m2crypto/Manifest
+++ b/dev-python/m2crypto/Manifest
@@ -1,5 +1,3 @@
-DIST M2Crypto-0.40.1.tar.gz 1266138 BLAKE2B a44de6b66695e0fbbba671682a7773ddbbd15225d27329d357e0005e395a70c6b006401ec30fb6938c9c4683377519844ea646df7c176181977139f6381c6907 SHA512 ca914de14621af4aa9b7f11664702557e596438cc76869478a2a75eb37ca14243e7064db7e32985834260ffa9136836884e60916d542a685ac3f1481b9320b69
DIST M2Crypto-0.41.0.tar.gz 1151680 BLAKE2B 6c5294294fd62ca69eec8222324ce8a1012c999aab241eba2e5b0085c0d7b598fd62f26e106bea95bfad3199abb2db9876547f521b34f45930b00540a6ecc24a SHA512 50ca5e32ae999b9ecdc7f3bbd35221b4a7523ef29e54eb4bc266457723117718955f99b9e7ac42a4cb982f0e22a94e5c852d6886d7dfb157d040ad86c17660fb
-EBUILD m2crypto-0.40.1.ebuild 1730 BLAKE2B 95f053448caf4c7a67f920b9cbad637878ea87f5890965b1f6cb6c144bea0226488d9412264cd705e847adae03a290483e59699ac0b7b57d6b9d5a2a4de72a82 SHA512 be514ce55d0d88ccac80490f49746644f9f6c202924daa03c22f11e092a579534fc08803edc57d364bb49b097c4cf84eae76276a2a60ef2722d1703dbc64749d
-EBUILD m2crypto-0.41.0.ebuild 1535 BLAKE2B fcf74f5159b0801274b50015cfc8d206c733598f34b51b8eee7cb682a6e4aa0b2ed27908df2ad1986047c8d0acd456f33127217228bb316267f51fd536ecd61c SHA512 52cfbae7e2ad7f618631bd9685ca46d9e1dadb2aacd4be3528637fbe5479fd29bbd463025a1663f23565c7693bca4013ec04df264533c6b1428d3b6af946365e
+EBUILD m2crypto-0.41.0.ebuild 1534 BLAKE2B be2bfeab8edd42079d19620f7969850a4637c43696bdd8ac6d671497f936cf5b7ae7c421fcb0be4337c7fead1060c0e4a65ffeee2806b111e5670ac1330bfe3f SHA512 47179533d3a44e060e505a0a49944732ecb81d0d5518bbdf9bdea2dac9cc62d6e124fbe26c0ca71d091c0806543cee52644b39f90a5c6ee3d3cb9fc5d480e168
MISC metadata.xml 381 BLAKE2B 9581f2ef53dd3b8bfff3724e91e36733892f9c4331376861ec25cee892d63f69f4f1846e46c40bc5a5045963d91aadcc2cdf70b574bf519557afe72cffab256b SHA512 95cfd7f65c912a520f371f236a49f41b711101f5997b14fa81f027cbcabe4bf6361d1a6f647d0de6e6b7756a2c662f2336c6dea5779d00372aa5b05f0566663d
diff --git a/dev-python/m2crypto/m2crypto-0.40.1.ebuild b/dev-python/m2crypto/m2crypto-0.40.1.ebuild
deleted file mode 100644
index e2cd29f218d2..000000000000
--- a/dev-python/m2crypto/m2crypto-0.40.1.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 2018-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-PYTHON_COMPAT=( python3_{10..12} )
-PYPI_NO_NORMALIZE=1
-PYPI_PN="M2Crypto"
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 toolchain-funcs pypi
-
-DESCRIPTION="A Python crypto and SSL toolkit"
-HOMEPAGE="
- https://gitlab.com/m2crypto/m2crypto/
- https://pypi.org/project/M2Crypto/
-"
-
-# openssl via src/SWIG/_lib11_compat.i
-LICENSE="MIT openssl"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="test abi_mips_n32 abi_mips_n64 abi_mips_o32"
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- >=dev-lang/swig-2.0.9
-"
-RDEPEND="
- dev-libs/openssl:=
-"
-DEPEND="${RDEPEND}"
-
-distutils_enable_tests setup.py
-
-swig_define() {
- local x
- for x; do
- if tc-cpp-is-true "defined(${x})"; then
- SWIG_FEATURES+=" -D${x}"
- fi
- done
-}
-
-src_prepare() {
- # relies on very exact clock behavior which apparently fails
- # with inconvenient CONFIG_HZ*
- sed -e 's:test_server_simple_timeouts:_&:' \
- -i tests/test_ssl.py || die
- distutils-r1_src_prepare
-}
-
-python_compile() {
- # setup.py looks at platform.machine() to determine swig options.
- # For exotic ABIs, we need to give swig a hint.
- local -x SWIG_FEATURES=
-
- # https://bugs.gentoo.org/617946
- swig_define __ILP32__
-
- # https://bugs.gentoo.org/674112
- swig_define __ARM_PCS_VFP
-
- # Avoid similar errors to bug #688668 for MIPS
- if use abi_mips_n32; then
- swig_define _MIPS_SIM = _ABIN32
- elif use abi_mips_n64; then
- swig_define _MIPS_SIM = _ABI64
- elif use abi_mips_o32; then
- swig_define _MIPS_SIM = _ABIO32
- fi
-
- distutils-r1_python_compile --openssl="${ESYSROOT}"/usr
-}
diff --git a/dev-python/m2crypto/m2crypto-0.41.0.ebuild b/dev-python/m2crypto/m2crypto-0.41.0.ebuild
index 97671f7f689a..6e63f27ac8f0 100644
--- a/dev-python/m2crypto/m2crypto-0.41.0.ebuild
+++ b/dev-python/m2crypto/m2crypto-0.41.0.ebuild
@@ -21,7 +21,7 @@ HOMEPAGE="
# openssl via src/SWIG/_lib11_compat.i
LICENSE="MIT openssl"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 ~sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
IUSE="abi_mips_n32 abi_mips_n64 abi_mips_o32"
DEPEND="