summaryrefslogtreecommitdiff
path: root/dev-python/lxml-html-clean/lxml-html-clean-0.1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/lxml-html-clean/lxml-html-clean-0.1.1.ebuild')
-rw-r--r--dev-python/lxml-html-clean/lxml-html-clean-0.1.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/lxml-html-clean/lxml-html-clean-0.1.1.ebuild b/dev-python/lxml-html-clean/lxml-html-clean-0.1.1.ebuild
new file mode 100644
index 000000000000..be9038fb8598
--- /dev/null
+++ b/dev-python/lxml-html-clean/lxml-html-clean-0.1.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Separate project for HTML cleaning functionalities copied from lxml.html.clean"
+HOMEPAGE="
+ https://pypi.org/project/lxml-html-clean/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm64"
+
+RDEPEND="
+ >=dev-python/lxml-5.2.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest