summaryrefslogtreecommitdiff
path: root/dev-python/lunr/lunr-0.5.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/lunr/lunr-0.5.8.ebuild')
-rw-r--r--dev-python/lunr/lunr-0.5.8.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-python/lunr/lunr-0.5.8.ebuild b/dev-python/lunr/lunr-0.5.8.ebuild
deleted file mode 100644
index fdf8b17158ab..000000000000
--- a/dev-python/lunr/lunr-0.5.8.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8} )
-
-DOCS_BUILDER="mkdocs"
-
-inherit distutils-r1 docs
-
-DESCRIPTION="A Python implementation of Lunr.js"
-HOMEPAGE="https://github.com/yeraydiazdiaz/lunr.py"
-SRC_URI="https://github.com/yeraydiazdiaz/lunr.py/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-RDEPEND="
- dev-python/future[${PYTHON_USEDEP}]
- dev-python/nltk[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-
-BDEPEND="test? (
- dev-python/mock[${PYTHON_USEDEP}]
-)"
-
-S="${WORKDIR}/${PN}.py-${PV}"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # Tests in this subdir all fail
- # Command '['node', '/var/tmp/portage/dev-python/lunr-0.5.8/work/lunr.py-0.5.8/tests/acceptance_tests/javascript/mkdocs_load_serialized_index_and_search.js', '/var/tmp/portage/dev-python/lunr-0.5.8/temp/tmpldbff36d', 'plugins']' returned non-zero exit status 1.
- rm -r tests/acceptance_tests || die
-
- distutils-r1_python_prepare_all
-}