summaryrefslogtreecommitdiff
path: root/dev-python/loguru/loguru-0.7.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/loguru/loguru-0.7.0.ebuild')
-rw-r--r--dev-python/loguru/loguru-0.7.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/loguru/loguru-0.7.0.ebuild b/dev-python/loguru/loguru-0.7.0.ebuild
new file mode 100644
index 000000000000..f776f2759d43
--- /dev/null
+++ b/dev-python/loguru/loguru-0.7.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python logging made (stupidly) simple"
+HOMEPAGE="
+ https://github.com/Delgan/loguru/
+ https://pypi.org/project/loguru/
+"
+SRC_URI="
+ https://github.com/Delgan/loguru/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+BDEPEND="
+ test? (
+ >=dev-python/colorama-0.4.6[${PYTHON_USEDEP}]
+ >=dev-python/freezegun-1.2.2[${PYTHON_USEDEP}]
+ )
+"
+
+# filesystem buffering tests may fail
+# on tmpfs with 64k PAGESZ, but pass fine on ext4
+distutils_enable_tests pytest