summaryrefslogtreecommitdiff
path: root/dev-python/logfury/logfury-1.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/logfury/logfury-1.0.1.ebuild')
-rw-r--r--dev-python/logfury/logfury-1.0.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/logfury/logfury-1.0.1.ebuild b/dev-python/logfury/logfury-1.0.1.ebuild
new file mode 100644
index 000000000000..c3e902babc3e
--- /dev/null
+++ b/dev-python/logfury/logfury-1.0.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Boilerplate library for logging method calls"
+HOMEPAGE="
+ https://github.com/reef-technologies/logfury
+ https://pypi.org/project/logfury/"
+SRC_URI="
+ https://github.com/reef-technologies/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/testfixtures[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # remove pin for old Pythons (sic!)
+ sed -i -e '/setuptools_scm/d' setup.py || die
+ distutils-r1_src_prepare
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+}