summaryrefslogtreecommitdiff
path: root/dev-python/lit
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/lit')
-rw-r--r--dev-python/lit/Manifest1
-rw-r--r--dev-python/lit/lit-17.0.0.9999.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/lit/Manifest b/dev-python/lit/Manifest
index 9052ea6afb23..f9c7dd54f675 100644
--- a/dev-python/lit/Manifest
+++ b/dev-python/lit/Manifest
@@ -12,4 +12,5 @@ EBUILD lit-15.0.6.ebuild 914 BLAKE2B 5ec2a2dc492bcd56b0f4461b5f2b9eb2a948327027b
EBUILD lit-15.0.7.ebuild 919 BLAKE2B 786b8915644183ff7abbfba1d43774fc5bc0997fcb99bf33a179474b21553a036b714c3eb39161557472a38c6f170ca86f713af5aa8f55cdd66fea809e97ea69 SHA512 9c3f1ebc0d64c1b9ecdf9dc86da1587e70a7fc31b3555ac8dfd0b98b28004acf493e08110d1261405d27c97ebf144c40efe808578b898d704ae28d7902511e7c
EBUILD lit-16.0.0.9999.ebuild 871 BLAKE2B cfd84e2b4e947055d576f1970754ba57228622c3a77d9c599392547b8bb3fb48165a69befde4e8e451cabb92b44917627f15bff46df91aa8825c2ac2c3289daf SHA512 13a9fe1650882edc1439217e401a5b2f0ca0886e44880d7cfcd1b7efda9b29441256a21e5cf0c65af719b0417f7612db0246e76cefe6c41b2442389f7c71b9cf
EBUILD lit-16.0.0_pre20230107.ebuild 877 BLAKE2B e0fb3eb26a481420f154c6c7306824e929cbea060ec0e28c28991c39f86f756ee5d004abf6c76775975e053a588df73b2fd121a55617621c8a179899adecb41d SHA512 9799e40aa5ad07879a049777666963e225ffc97618fdae22869e8c8a648b0e33554859c525fad2307e23b96616bf24847c1ad7aa3e69353927c03f975b3bcbb8
+EBUILD lit-17.0.0.9999.ebuild 871 BLAKE2B cfd84e2b4e947055d576f1970754ba57228622c3a77d9c599392547b8bb3fb48165a69befde4e8e451cabb92b44917627f15bff46df91aa8825c2ac2c3289daf SHA512 13a9fe1650882edc1439217e401a5b2f0ca0886e44880d7cfcd1b7efda9b29441256a21e5cf0c65af719b0417f7612db0246e76cefe6c41b2442389f7c71b9cf
MISC metadata.xml 340 BLAKE2B c9ca851e49b4ab48c015686e983ec988f60c34ed0af77abd7bc03d046002f79f74b9b463ecb97db89f2230c1593af7acdaf6651fc51fed4aa92a459d07aabf18 SHA512 3fe8262ce6b971364162fbdbac3b02bf02f0a64896c8a2564e2a2998bd6e6bc74463bf9104e3f4ffaa9f5c1a16c877fc864b8a4f056ca0022f741799bc00f217
diff --git a/dev-python/lit/lit-17.0.0.9999.ebuild b/dev-python/lit/lit-17.0.0.9999.ebuild
new file mode 100644
index 000000000000..f4b401a77373
--- /dev/null
+++ b/dev-python/lit/lit-17.0.0.9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 llvm.org
+
+DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# Tests require 'FileCheck' and 'not' utilities (from llvm)
+BDEPEND="
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ sys-devel/llvm
+ )
+"
+
+LLVM_COMPONENTS=( llvm/utils/lit )
+llvm.org_set_globals
+
+# TODO: move the manpage generation here (from sys-devel/llvm)
+
+src_prepare() {
+ cd "${WORKDIR}" || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x LIT_PRESERVES_TMP=1
+ local litflags=$(get_lit_flags)
+ ./lit.py ${litflags//;/ } tests || die
+}