summaryrefslogtreecommitdiff
path: root/dev-python/lit/lit-4.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/lit/lit-4.0.1.ebuild')
-rw-r--r--dev-python/lit/lit-4.0.1.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/dev-python/lit/lit-4.0.1.ebuild b/dev-python/lit/lit-4.0.1.ebuild
deleted file mode 100644
index 4e620171d645..000000000000
--- a/dev-python/lit/lit-4.0.1.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-inherit distutils-r1
-
-MY_P=llvm-${PV/_/}
-DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
-HOMEPAGE="https://llvm.org/"
-SRC_URI="https://releases.llvm.org/${PV/_//}/${MY_P}.src.tar.xz"
-
-LICENSE="UoI-NCSA"
-SLOT="0"
-KEYWORDS="amd64 arm ~arm64 x86"
-IUSE="test"
-
-S=${WORKDIR}/${MY_P}.src/utils/lit
-
-# Tests require 'FileCheck' and 'not' utilities (from llvm)
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/psutil[${PYTHON_USEDEP}]
- sys-devel/llvm )"
-
-# Tests are broken in this version, fixed in 5.0+.
-RESTRICT="test"
-
-# TODO: move the manpage generation here (from sys-devel/llvm)
-
-python_test() {
- ./lit.py -sv tests || die
-}