summaryrefslogtreecommitdiff
path: root/dev-python/lit/lit-18.1.0_rc3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/lit/lit-18.1.0_rc3.ebuild')
-rw-r--r--dev-python/lit/lit-18.1.0_rc3.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/lit/lit-18.1.0_rc3.ebuild b/dev-python/lit/lit-18.1.0_rc3.ebuild
deleted file mode 100644
index 3d0315962098..000000000000
--- a/dev-python/lit/lit-18.1.0_rc3.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 llvm.org
-
-DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
-HOMEPAGE="https://llvm.org/"
-
-LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-# Tests require 'FileCheck' and 'not' utilities (from llvm)
-BDEPEND="
- test? (
- dev-python/psutil[${PYTHON_USEDEP}]
- sys-devel/llvm
- )
-"
-
-LLVM_COMPONENTS=( llvm/utils/lit )
-llvm.org_set_globals
-
-# TODO: move the manpage generation here (from sys-devel/llvm)
-
-src_prepare() {
- # flaky test
- # https://github.com/llvm/llvm-project/issues/72022
- rm tests/progress-bar.py || die
-
- cd "${WORKDIR}" || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- local -x LIT_PRESERVES_TMP=1
- local litflags=$(get_lit_flags)
- ./lit.py ${litflags//;/ } tests || die
-}