summaryrefslogtreecommitdiff
path: root/dev-python/line_profiler/line_profiler-1.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/line_profiler/line_profiler-1.0-r1.ebuild')
-rw-r--r--dev-python/line_profiler/line_profiler-1.0-r1.ebuild32
1 files changed, 0 insertions, 32 deletions
diff --git a/dev-python/line_profiler/line_profiler-1.0-r1.ebuild b/dev-python/line_profiler/line_profiler-1.0-r1.ebuild
deleted file mode 100644
index 6dbe4b315ca2..000000000000
--- a/dev-python/line_profiler/line_profiler-1.0-r1.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5} )
-
-inherit distutils-r1
-
-DESCRIPTION="Line-by-line profiler"
-HOMEPAGE="https://github.com/rkern/line_profiler"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-KEYWORDS="~amd64"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-DEPEND="
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
- "
-
-PATCHES=(
- "${FILESDIR}/${P}-fix-name-from-copypasta.patch"
- "${FILESDIR}/${P}-ipython-5.0-compatibility.patch"
-)
-
-python_test() {
- "${PYTHON}" -m unittest discover -v "${S}"/tests/ \
- || die "Tests failed with ${EPYTHON}"
-}