summaryrefslogtreecommitdiff
path: root/dev-python/libtmux/libtmux-0.30.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/libtmux/libtmux-0.30.2.ebuild')
-rw-r--r--dev-python/libtmux/libtmux-0.30.2.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-python/libtmux/libtmux-0.30.2.ebuild b/dev-python/libtmux/libtmux-0.30.2.ebuild
index 3347c96865a2..8dcc7ee19960 100644
--- a/dev-python/libtmux/libtmux-0.30.2.ebuild
+++ b/dev-python/libtmux/libtmux-0.30.2.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{9..12} pypy3 )
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
inherit distutils-r1
@@ -53,5 +53,8 @@ python_test() {
local -a EPYTEST_DESELECT=(
libtmux/pane.py::libtmux.pane.Pane.send_keys
)
+ # tests/test_window.py::test_fresh_window_data fails if TMUX_PANE is set
+ # https://bugs.gentoo.org/927158
+ local -x TMUX_PANE=
epytest
}