summaryrefslogtreecommitdiff
path: root/dev-python/libsass
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/libsass')
-rw-r--r--dev-python/libsass/Manifest2
-rw-r--r--dev-python/libsass/libsass-0.22.0.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/libsass/Manifest b/dev-python/libsass/Manifest
index daefd8352439..8cc454daef92 100644
--- a/dev-python/libsass/Manifest
+++ b/dev-python/libsass/Manifest
@@ -1,4 +1,6 @@
AUX libsass-0.20.0_rename_sassc.patch 1710 BLAKE2B 410f1256dbe433d5836a0c7f94a30b0fbe174285408d5c3c0589a7f4f58d2417c9be37af6ae137031365450ad2bca51ebb2cd6083c625d95a33ac8c0eb3bc80e SHA512 3e30b6a5cc387aac526ca2159d5854b28090ab41d7d4b2512627cc1e5b392569b81c0b1c845d3311a9cd44c73a6ed109b2a06a9677cbe15a4a39c7ab0c7c4a6d
DIST libsass-python-0.21.0.gh.tar.gz 55774 BLAKE2B 3c584ff3b6c09bc768554a3a4f7ef28ecea0726f59206da8540f9c1b4db74ab1235695074dd6b95db74f174066bb856c9854026525da82e7763f341920f0bd53 SHA512 d5b7a1bf0dc736a6a38e2e609f0a213306de31d5ad84cfdcd96f9ff72a1c38f15bad3cf25a1cec6dca5a9f3b00a8509afff2b4ea5e4db80e218e3ae603d55856
+DIST libsass-python-0.22.0.gh.tar.gz 55135 BLAKE2B 8495462fa8e6a68bf73ecdf68771c577bad1affa1121c1781dac41c912aae731df88c2b1d1a4ef363e50a98ff1b471e7c45562faa6f2425e8ec5f47f9cf76c6c SHA512 13914b60fe19fc70d197a948a2bc83f7646e4acaa45caed6df68bf2eb10e0a7ef811cdbbcc7a4338f9c1433cba8e316146c20072dc4ff34f51e094ead1bfdcd7
EBUILD libsass-0.21.0-r1.ebuild 1561 BLAKE2B 173e244f5e492d3d3c4088a58bfbca988948b3e91bb7e787a952e0131ea26b5f987422f4c8343513e50f8f4902ee96e709a69f2eb409ea9331f184d390ff577f SHA512 9e60278ec5720c9dabe2e8f75a17f71db48bb669a22f13dda5d5c2d8f47a2b546dd080a38e5c058ed065143b49074401848ac142f83f9a4958867b5fd33b1c6f
+EBUILD libsass-0.22.0.ebuild 1225 BLAKE2B 1c0dba3f3c7ba49fda9a3c431a75534216693a661524726cfa274075d52ad3d85a7c3b002dd488ab6c06958443ece4a403be202fca238092b45579272a359c82 SHA512 dbbefd828f9ff32805ceb4b41cb392ed78cd7b0385629a4421220ec1dbb5adcfd4c7eae92fc3aaabe069d78dd6da359239f8391170976115b9b88c7c1f9d4d1a
MISC metadata.xml 430 BLAKE2B 6d9f1d6a435110869d11d460136c6e1ede1119110111de1fd737caa92f52688a305645478542efc9a33f30f5534b55421ab63470db342a781b5f8f008048ba3f SHA512 b6dc1c8363dc915ad1ee1d6d1ec4f7599625648c0d75d4b159215069716a8e60f0efc72ad846cf59f7cf2736d083f4e37784c818d287b38e06b066b997c2f3ae
diff --git a/dev-python/libsass/libsass-0.22.0.ebuild b/dev-python/libsass/libsass-0.22.0.ebuild
new file mode 100644
index 000000000000..895dfea5ba99
--- /dev/null
+++ b/dev-python/libsass/libsass-0.22.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+MY_P="libsass-python-${PV}"
+DESCRIPTION="A straightforward binding of libsass for Python"
+HOMEPAGE="
+ https://github.com/sass/libsass-python/
+ https://pypi.org/project/libsass/
+"
+SRC_URI="
+ https://github.com/sass/libsass-python/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=dev-libs/libsass-3.6.5
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ test? (
+ dev-python/PyQt5[testlib,${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ echo "${PV}" > .libsass-upstream-version || die
+ distutils-r1_src_prepare
+ export SYSTEM_SASS=1
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # probably broken by removal of sassc
+ sasstests.py::SasscTestCase::test_sassc_stdout
+ # skip the pip tests because they need an internet connection
+ # not relevant for gentoo anyway
+ sasstests.py::DistutilsTestCase::test_build_sass
+ sasstests.py::DistutilsTestCase::test_output_style
+ )
+
+ epytest sasstests.py
+}