summaryrefslogtreecommitdiff
path: root/dev-python/libcloud
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/libcloud')
-rw-r--r--dev-python/libcloud/Manifest2
-rw-r--r--dev-python/libcloud/libcloud-3.3.0.ebuild14
2 files changed, 9 insertions, 7 deletions
diff --git a/dev-python/libcloud/Manifest b/dev-python/libcloud/Manifest
index 64b43c4833a3..e30c97727c43 100644
--- a/dev-python/libcloud/Manifest
+++ b/dev-python/libcloud/Manifest
@@ -1,3 +1,3 @@
DIST apache-libcloud-3.3.0.tar.bz2 1811722 BLAKE2B bfdacdda6bb39b3782915d71db6d736caa8a1d57c5120dac9020a1c4923ab08bf8983916fcac15723139b073858efdf178aa797dd592d7534a0b6ff35f8fc5ae SHA512 286ddd79b14633ceb59e1a4b015760a1e525b0282f3039f16c2fa4de940005da5fbde1b8262027103ca91c9653baed22d61dd136ddcc2b6886687ad8b27f3ea8
-EBUILD libcloud-3.3.0.ebuild 1200 BLAKE2B 3c278b434fb196fd1b39dab3962daf133aed125af9b001234795b6257a05c5de665de5c89f7fdbb4e48ecd6fe8abd805be2e02d2ee9ada49b5733f512e5d85a4 SHA512 70461bcc5ba5332259c68e18373736110f111148dc80d6df98b450ff43146ecdf5a9eb7f117b092f705c0535f7d5eaaf9727d3f8b4dc21efec48ac5d1b5bb9bc
+EBUILD libcloud-3.3.0.ebuild 1241 BLAKE2B 870271718b9b120997d01c4b6255fe8070b2e7a8570a122b041ba6db00a3bfca209ea5a9b40124e634210241b3e00bd818289e6dc099bb1e180d5157c8679768 SHA512 62f8b3cc20dd157d58da7a401ec9074955da5ab774d5f9b0794a6c37ed7d05d1f17f2de4a82b524a30a5dfb5fcf519f97a4202d5605e282eaeecd34598c0bc03
MISC metadata.xml 324 BLAKE2B aa05dc2d968f9550a607cc367c5ab6c3426a41e35cc9a29baaf25050978543fee5bdd676a4606c45fd9104ab6dbe2f2c2bf8f7c45d1b95805503f1cf20668b75 SHA512 809416c2bc54a84624712c77982b57734b6510c66dc731f517574949f13b2aa37b97c9ce4e5ea649262a4731a435187f271d0922e87bc647b2e696bfb40eab0d
diff --git a/dev-python/libcloud/libcloud-3.3.0.ebuild b/dev-python/libcloud/libcloud-3.3.0.ebuild
index eae3be8212e2..0c5711501b8b 100644
--- a/dev-python/libcloud/libcloud-3.3.0.ebuild
+++ b/dev-python/libcloud/libcloud-3.3.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="ssl(+)"
inherit distutils-r1
@@ -18,11 +18,11 @@ SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 x86"
IUSE="examples"
-RDEPEND=">=dev-python/requests-2.5.0[${PYTHON_USEDEP}]"
-
-distutils_enable_tests pytest
-
-BDEPEND+="
+RDEPEND="
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.5.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
test? (
>=dev-python/cryptography-2.6.1[${PYTHON_USEDEP}]
dev-python/lockfile[${PYTHON_USEDEP}]
@@ -31,6 +31,8 @@ BDEPEND+="
)
"
+distutils_enable_tests pytest
+
python_prepare_all() {
if use examples; then
mkdir examples || die