summaryrefslogtreecommitdiff
path: root/dev-python/lark/lark-1.1.9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/lark/lark-1.1.9.ebuild')
-rw-r--r--dev-python/lark/lark-1.1.9.ebuild12
1 files changed, 4 insertions, 8 deletions
diff --git a/dev-python/lark/lark-1.1.9.ebuild b/dev-python/lark/lark-1.1.9.ebuild
index 140ffaaa34e1..302e7201818e 100644
--- a/dev-python/lark/lark-1.1.9.ebuild
+++ b/dev-python/lark/lark-1.1.9.ebuild
@@ -18,10 +18,13 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~arm64-macos ~x64-macos"
+# dev-python/regex doesn't support pypy
BDEPEND="
test? (
dev-python/atomicwrites[${PYTHON_USEDEP}]
- dev-python/regex[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/regex[${PYTHON_USEDEP}]
+ ' 'python*')
)
"
@@ -33,12 +36,5 @@ python_test() {
tests/test_nearley/test_nearley.py
)
- if has "${EPYTHON}" pypy3 python3.{8,9}; then
- EPYTEST_IGNORE+=(
- # test using Python 3.10+ syntax
- tests/test_pattern_matching.py
- )
- fi
-
epytest
}