summaryrefslogtreecommitdiff
path: root/dev-python/krb5/krb5-0.4.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/krb5/krb5-0.4.1.ebuild')
-rw-r--r--dev-python/krb5/krb5-0.4.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/krb5/krb5-0.4.1.ebuild b/dev-python/krb5/krb5-0.4.1.ebuild
new file mode 100644
index 000000000000..ab0d23e77af0
--- /dev/null
+++ b/dev-python/krb5/krb5-0.4.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Kerberos API bindings for Python"
+HOMEPAGE="
+ https://github.com/jborean93/pykrb5/
+ https://pypi.org/project/krb5/
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ virtual/krb5
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/k5test[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest