summaryrefslogtreecommitdiff
path: root/dev-python/kombu/kombu-5.3.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/kombu/kombu-5.3.7.ebuild')
-rw-r--r--dev-python/kombu/kombu-5.3.7.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-python/kombu/kombu-5.3.7.ebuild b/dev-python/kombu/kombu-5.3.7.ebuild
index fc9d24aa3243..8d4a9966b9e7 100644
--- a/dev-python/kombu/kombu-5.3.7.ebuild
+++ b/dev-python/kombu/kombu-5.3.7.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1 optfeature pypi
@@ -45,6 +45,11 @@ distutils_enable_tests pytest
distutils_enable_sphinx docs \
dev-python/sphinx-celery
+PATCHES=(
+ # https://github.com/celery/kombu/pull/2052
+ "${FILESDIR}/${P}-py313.patch"
+)
+
python_test() {
local EPYTEST_DESELECT=(
# TODO