summaryrefslogtreecommitdiff
path: root/dev-python/kiwisolver/kiwisolver-1.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/kiwisolver/kiwisolver-1.1.0.ebuild')
-rw-r--r--dev-python/kiwisolver/kiwisolver-1.1.0.ebuild15
1 files changed, 15 insertions, 0 deletions
diff --git a/dev-python/kiwisolver/kiwisolver-1.1.0.ebuild b/dev-python/kiwisolver/kiwisolver-1.1.0.ebuild
new file mode 100644
index 000000000000..abc747aef0ed
--- /dev/null
+++ b/dev-python/kiwisolver/kiwisolver-1.1.0.ebuild
@@ -0,0 +1,15 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="An efficient C++ implementation of the Cassowary constraint solving algorithm"
+HOMEPAGE="https://github.com/nucleic/kiwi"
+SRC_URI="https://github.com/nucleic/kiwi/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Clear-BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+S="${WORKDIR}"/kiwi-${PV}