summaryrefslogtreecommitdiff
path: root/dev-python/kid/kid-0.9.6-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/kid/kid-0.9.6-r1.ebuild')
-rw-r--r--dev-python/kid/kid-0.9.6-r1.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-python/kid/kid-0.9.6-r1.ebuild b/dev-python/kid/kid-0.9.6-r1.ebuild
deleted file mode 100644
index e573163108ac..000000000000
--- a/dev-python/kid/kid-0.9.6-r1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="A simple and Pythonic XML template language"
-HOMEPAGE="http://www.kid-templating.org/ https://pypi.org/project/kid/"
-SRC_URI="http://www.kid-templating.org/dist/${PV}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~ia64 x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=""
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/docutils[${PYTHON_USEDEP}] )"
-
-DOCS=( README doc/{guide.txt,index.txt,notes.txt} )
-
-python_compile_all() {
- use doc && emake -C doc
-}
-
-python_test() {
- py.test -xl || die
-}
-
-python_install_all() {
-# dobin bin/*
-
- use doc && local HTML_DOCS=( doc/html/. )
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
- distutils-r1_python_install_all
-}