summaryrefslogtreecommitdiff
path: root/dev-python/jwcrypto
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jwcrypto')
-rw-r--r--dev-python/jwcrypto/Manifest2
-rw-r--r--dev-python/jwcrypto/jwcrypto-1.5.5.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/jwcrypto/Manifest b/dev-python/jwcrypto/Manifest
index 849b6a38d729..57c2b804a6e9 100644
--- a/dev-python/jwcrypto/Manifest
+++ b/dev-python/jwcrypto/Manifest
@@ -1,3 +1,5 @@
DIST jwcrypto-1.5.4.gh.tar.gz 96607 BLAKE2B a1558c58c26e6ecb3747c6e7d554bd2100fd8f3c9c5804cf2a596c55920399e879dad267bcbc162aab0b956bde129cdb0090af98171eb7cb06970ed0964f47d9 SHA512 085adfd5f894ee8215c70371d2ebc2e97a38efb17be14ee8433858474df906ff963f243f669e209624e7ec78c1eb8b5ccc2077f0fc50b4e5eef25885e338b4e1
+DIST jwcrypto-1.5.5.gh.tar.gz 96792 BLAKE2B 3c85f62936da7b69ec5f2aa0452f9696a349288554626c98c9e1c0ef31b5e4098520a588bcacb0d3d34d47c35c8556728551804ea01cca747ceb5e3c15497014 SHA512 a69ae9323a6f6d66cf7f47b57106ca81446627926d0e39223bcde51a1b520b07de823b7c023b7ac3a53a539273a5155c0490e5b4309a6fb81bcefa3685b6258c
EBUILD jwcrypto-1.5.4.ebuild 860 BLAKE2B 613b45d89e37f0af12f2ea71a7f0fe46bbbd584cffd97659526d92c878e816e540227aca4f7f100580e3528a9f92753366386fd4b2d7fdb11b6f0fcc993810a7 SHA512 c4afa93dd773fc5a25102e94ffcce8afd2f1749e6fe56be52080b393d53ada00ff8f14370cc07847456395d587bdc95770c715c46259f588165984abaacc34a6
+EBUILD jwcrypto-1.5.5.ebuild 863 BLAKE2B e9eb2ea0e10771c3ba4d33fa79f069d9f9db99dbd952ec39d195eed5aaa85263783a08354d5ef89a2f17df7e6218d28948ec1abb5f378ced861f60aa977a4796 SHA512 1eed8300d7c3f531b00b118fab12197ca0100d41ab1ed82e775e248f25bae63c6021f8e56a7f0f3c90da4ca08ae29772402968b28304598161e7ee76d0304af4
MISC metadata.xml 369 BLAKE2B c7868e0b20a2875964290642cddb457b71628e361f0e032875ac45f4405abeb76c8c53bcfe623c9a2e49ea6e184505503b4e43f34c456528ff3250aea5110b10 SHA512 a1fec6ac31bbb096e508b0ebd644aa8a96418e6972d852512d4b7702b67f241f858610235dbd68430c588d8b837c7a0866f333c8aab182e7cd01e10325031d34
diff --git a/dev-python/jwcrypto/jwcrypto-1.5.5.ebuild b/dev-python/jwcrypto/jwcrypto-1.5.5.ebuild
new file mode 100644
index 000000000000..aa90a1f6e229
--- /dev/null
+++ b/dev-python/jwcrypto/jwcrypto-1.5.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Implements JWK,JWS,JWE specifications using python-cryptography"
+HOMEPAGE="
+ https://github.com/latchset/jwcrypto/
+ https://pypi.org/project/jwcrypto/
+"
+SRC_URI="
+ https://github.com/latchset/jwcrypto/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/cryptography-3.4[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.5.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs/source
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Do not install doc in non-standard paths
+ sed -e "/data_files/d" -i setup.py || die
+ distutils-r1_python_prepare_all
+}