summaryrefslogtreecommitdiff
path: root/dev-python/jwcrypto/jwcrypto-0.8.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jwcrypto/jwcrypto-0.8.0.ebuild')
-rw-r--r--dev-python/jwcrypto/jwcrypto-0.8.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/jwcrypto/jwcrypto-0.8.0.ebuild b/dev-python/jwcrypto/jwcrypto-0.8.0.ebuild
new file mode 100644
index 000000000000..babe4d90871f
--- /dev/null
+++ b/dev-python/jwcrypto/jwcrypto-0.8.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Implements JWK,JWS,JWE specifications using python-cryptography"
+
+HOMEPAGE="https://github.com/latchset/jwcrypto"
+SRC_URI="https://github.com/latchset/jwcrypto/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND=">=dev-python/cryptography-2.3[${PYTHON_USEDEP}]"
+
+distutils_enable_sphinx docs/source
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Do not install doc in non-standard paths
+ sed -i "\|data_files = \[('share/doc/jwcrypto|d" setup.py || die
+ distutils-r1_python_prepare_all
+}