summaryrefslogtreecommitdiff
path: root/dev-python/jupyterlab_server/jupyterlab_server-2.10.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jupyterlab_server/jupyterlab_server-2.10.3.ebuild')
-rw-r--r--dev-python/jupyterlab_server/jupyterlab_server-2.10.3.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/jupyterlab_server/jupyterlab_server-2.10.3.ebuild b/dev-python/jupyterlab_server/jupyterlab_server-2.10.3.ebuild
deleted file mode 100644
index a052c2fbd539..000000000000
--- a/dev-python/jupyterlab_server/jupyterlab_server-2.10.3.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1
-
-DESCRIPTION="Server components for JupyterLab and JupyterLab like applications"
-HOMEPAGE="https://jupyter.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-
-# TODO: package openapi et al
-RESTRICT="test"
-
-RDEPEND="
- dev-python/Babel[${PYTHON_USEDEP}]
- >=dev-python/entrypoints-0.2.2[${PYTHON_USEDEP}]
- >=dev-python/jinja-2.10[${PYTHON_USEDEP}]
- dev-python/json5[${PYTHON_USEDEP}]
- >=dev-python/jsonschema-3.0.1[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- >=dev-python/jupyter_server-1.4[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-# TODO: package autodoc_traits
-#distutils_enable_sphinx docs/source dev-python/pydata-sphinx-theme dev-python/myst_parser
-
-python_prepare_all() {
- # Do not depend on pytest-cov
- sed -i -e '/addopts/d' pyproject.toml || die
-
- # Defining 'pytest_plugins' in a non-top-level conftest is no longer supported:
- mv ${PN}/tests/conftest.py . || die
-
- distutils-r1_python_prepare_all
-}