summaryrefslogtreecommitdiff
path: root/dev-python/jupyterlab-server
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jupyterlab-server')
-rw-r--r--dev-python/jupyterlab-server/Manifest5
-rw-r--r--dev-python/jupyterlab-server/jupyterlab-server-2.19.0.ebuild67
-rw-r--r--dev-python/jupyterlab-server/jupyterlab-server-2.20.0.ebuild69
-rw-r--r--dev-python/jupyterlab-server/metadata.xml13
4 files changed, 154 insertions, 0 deletions
diff --git a/dev-python/jupyterlab-server/Manifest b/dev-python/jupyterlab-server/Manifest
new file mode 100644
index 000000000000..4d341feac9e5
--- /dev/null
+++ b/dev-python/jupyterlab-server/Manifest
@@ -0,0 +1,5 @@
+DIST jupyterlab_server-2.19.0.tar.gz 69979 BLAKE2B f44eea3aa2a19c0f2e548b33e1677a8daf4b6098bfb682f3ebae816d38c6cd24769aea35053f2a9e656e5b2bba2a032d4bd75ba976d30238fa4d27c9a1a69867 SHA512 058a1663ca1d6663be9de1243b178637a61e2ff156ca00163d9f30301d8527ca26235f1d3183bc2b48b6b4b82dbea595a4c7f0a989736b603851f5d78f8da078
+DIST jupyterlab_server-2.20.0.tar.gz 70481 BLAKE2B 188b8a9bd2bfc5a27ce6f8488d7768484fd71ae8bb93f28c8a49f63b1aef13551c55d7e18531830df26617883f6b780a491d3522a0dcb3ecddcc433cfb35f97b SHA512 7d9a86f56686344ffc1ad11a9fc7c736a2ac0e6b8c31f8b6d8e35e5fd982454b2362073038dfc2ed3a4f03ef53e2afcaa33fc2c956b63e44c3d1ae6efa1f9251
+EBUILD jupyterlab-server-2.19.0.ebuild 1857 BLAKE2B cf65a6e2511d3c21e20fa595b1f07492078daaa858d669129d73d9e08694adf6da95aeb4443cd4715a47f5d25ce792d4d810146ebdb847de6eebd3241d822d39 SHA512 85d202b3d99943fad02953fae7a72f62e54258f781dbed0d380b91965e80aec7f94cb0ddd9b77cd458e5bd6a7b6be0b8f3e33938b8f05e1e3b19634af5cf4f84
+EBUILD jupyterlab-server-2.20.0.ebuild 1966 BLAKE2B 04a8980c5de59b110523b01d140ed2722e99502c2fc31b2c8beece116d8883fb9dc9827022302b425a153692d3e7fa10a1074142af324420e6d61ba2cb8382c5 SHA512 768c7006fd1b9dfd637d1a063f4def42a6fad50e34393f7c2ed6928f0c06cbd6c548d99fe2ffafc62aca9987e2a821b3e7f12f134f71a956fcb937f2e81ec4d9
+MISC metadata.xml 426 BLAKE2B 98083ff6255b6c5b4ebe7eb67f4e9716f52397646df275cce4cae2f78b0fbb5dda8d6240e1546b4bac6f13ef3f3f1e6f176b2062e066070d595e5cd93c02708e SHA512 9755e74547fb74a4720c9b755449d913dbfd949bad920ecd3903df91182236ad46712c358b3db8180ddf478a6cc6c2a57c6d1a939a9911ffc7ccb39672f5868e
diff --git a/dev-python/jupyterlab-server/jupyterlab-server-2.19.0.ebuild b/dev-python/jupyterlab-server/jupyterlab-server-2.19.0.ebuild
new file mode 100644
index 000000000000..89d3aefe8a12
--- /dev/null
+++ b/dev-python/jupyterlab-server/jupyterlab-server-2.19.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=hatchling
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Server components for JupyterLab and JupyterLab like applications"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyterlab/jupyterlab_server/
+ https://pypi.org/project/jupyterlab-server/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/Babel-2.10[${PYTHON_USEDEP}]
+ >=dev-python/jinja-3.0.3[${PYTHON_USEDEP}]
+ >=dev-python/json5-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0.1[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.28[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_server-1.21[${PYTHON_USEDEP}]
+ <dev-python/jupyter_server-3[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-4.8.3[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+"
+
+BDEPEND="
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/jupyter_server[${PYTHON_USEDEP}]
+ >=dev-python/openapi-core-0.16.1[${PYTHON_USEDEP}]
+ >=dev-python/openapi-spec-validator-0.5.1[${PYTHON_USEDEP}]
+ dev-python/pytest_jupyter[${PYTHON_USEDEP}]
+ dev-python/pytest-tornasync[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ dev-python/strict-rfc3339[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+# TODO: package autodoc_traits
+#distutils_enable_sphinx docs/source dev-python/pydata-sphinx-theme dev-python/myst-parser
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ tests/test_translation_api.py
+ )
+
+ EPYTEST_DESELECT=(
+ # Fails if terminal not available
+ tests/test_labapp.py::test_page_config
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_tornasync.plugin
+}
diff --git a/dev-python/jupyterlab-server/jupyterlab-server-2.20.0.ebuild b/dev-python/jupyterlab-server/jupyterlab-server-2.20.0.ebuild
new file mode 100644
index 000000000000..6280fed7052a
--- /dev/null
+++ b/dev-python/jupyterlab-server/jupyterlab-server-2.20.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=hatchling
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Server components for JupyterLab and JupyterLab like applications"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyterlab/jupyterlab_server/
+ https://pypi.org/project/jupyterlab-server/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/Babel-2.10[${PYTHON_USEDEP}]
+ >=dev-python/jinja-3.0.3[${PYTHON_USEDEP}]
+ >=dev-python/json5-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0.1[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.28[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_server-1.21[${PYTHON_USEDEP}]
+ <dev-python/jupyter_server-3[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-4.8.3[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+"
+
+BDEPEND="
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/jupyter_server[${PYTHON_USEDEP}]
+ <dev-python/openapi-core-0.17[${PYTHON_USEDEP}]
+ >=dev-python/openapi-core-0.16.1[${PYTHON_USEDEP}]
+ <dev-python/openapi-spec-validator-0.6[${PYTHON_USEDEP}]
+ >=dev-python/openapi-spec-validator-0.5.1[${PYTHON_USEDEP}]
+ dev-python/pytest_jupyter[${PYTHON_USEDEP}]
+ dev-python/pytest-tornasync[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ dev-python/strict-rfc3339[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+# TODO: package autodoc_traits
+#distutils_enable_sphinx docs/source dev-python/pydata-sphinx-theme dev-python/myst-parser
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ tests/test_translation_api.py
+ )
+
+ EPYTEST_DESELECT=(
+ # Fails if terminal not available
+ tests/test_labapp.py::test_page_config
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_tornasync.plugin
+}
diff --git a/dev-python/jupyterlab-server/metadata.xml b/dev-python/jupyterlab-server/metadata.xml
new file mode 100644
index 000000000000..83cc6e188b12
--- /dev/null
+++ b/dev-python/jupyterlab-server/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">jupyterlab-server</remote-id>
+ <remote-id type="github">jupyterlab/jupyterlab_server</remote-id>
+ </upstream>
+</pkgmetadata>