summaryrefslogtreecommitdiff
path: root/dev-python/jupyter_packaging/jupyter_packaging-0.12.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jupyter_packaging/jupyter_packaging-0.12.0.ebuild')
-rw-r--r--dev-python/jupyter_packaging/jupyter_packaging-0.12.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/jupyter_packaging/jupyter_packaging-0.12.0.ebuild b/dev-python/jupyter_packaging/jupyter_packaging-0.12.0.ebuild
new file mode 100644
index 000000000000..5d4545dcf81d
--- /dev/null
+++ b/dev-python/jupyter_packaging/jupyter_packaging-0.12.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Tools to help build and install Jupyter Python packages"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/tomlkit[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ dev-python/deprecation[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/build[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # require Internet
+ tests/test_build_api.py::test_build_package
+ tests/test_build_api.py::test_deprecated_metadata
+)
+
+src_prepare() {
+ # https://github.com/jupyter/jupyter-packaging/pull/135
+ cat >> setup.cfg <<-EOF
+ [options.packages.find]
+ exclude = tests
+ EOF
+
+ distutils-r1_src_prepare
+}