summaryrefslogtreecommitdiff
path: root/dev-python/jupyter_events/jupyter_events-0.5.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jupyter_events/jupyter_events-0.5.0.ebuild')
-rw-r--r--dev-python/jupyter_events/jupyter_events-0.5.0.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/jupyter_events/jupyter_events-0.5.0.ebuild b/dev-python/jupyter_events/jupyter_events-0.5.0.ebuild
deleted file mode 100644
index bb2056984222..000000000000
--- a/dev-python/jupyter_events/jupyter_events-0.5.0.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Jupyter Event System library"
-HOMEPAGE="https://jupyter.org"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~x86"
-
-RDEPEND="
- >=dev-python/jsonschema-4.3.0[${PYTHON_USEDEP}]
- dev-python/python-json-logger[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/traitlets[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/click[${PYTHON_USEDEP}]
- dev-python/rich[${PYTHON_USEDEP}]
- )
-"
-
-# TODO: package jupyterlite-sphinx
-# distutils_enable_sphinx docs
-distutils_enable_tests pytest