summaryrefslogtreecommitdiff
path: root/dev-python/jupyter-client
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jupyter-client')
-rw-r--r--dev-python/jupyter-client/Manifest2
-rw-r--r--dev-python/jupyter-client/jupyter-client-8.6.1.ebuild56
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/jupyter-client/Manifest b/dev-python/jupyter-client/Manifest
index 20c8702596c7..8c52309b2368 100644
--- a/dev-python/jupyter-client/Manifest
+++ b/dev-python/jupyter-client/Manifest
@@ -1,3 +1,5 @@
DIST jupyter_client-8.6.0.tar.gz 339721 BLAKE2B 80786453526899cfff2e5335009d90f0dd636da33a5778868ba8913be488e9c1512beffc1b5e658dee215bdee9e264c9a5c6621490c2efb8f4784557735f736e SHA512 84e913c46f5e0298b699c4d1c6de27fd2b9861bc29f7a5a456c20c7100aaedf399eb6c09ff28bd3bb20945a3bea84bd0bda8688f32815fa7bdd375f091817e4a
+DIST jupyter_client-8.6.1.tar.gz 340957 BLAKE2B a9a7e7818a463927ec11a4adc6758addef38fae45e29be59b388951715898e5bc81e02035c33fa6e4a0208db47a87a2b793258f4a85739925827895ea357b8f8 SHA512 be70d1f250da6698998a5c523d733da386940952487335e615160e04600e00e7ff170cae7f0c03e3a000ecca2bac26855f100c95f2759983c0b50fde10ed8223
EBUILD jupyter-client-8.6.0.ebuild 1339 BLAKE2B cf36533b06c5e29783705a8920727d702769d74e50d7facc0354d51a2d99d5865991083c495a8fe9f3fd25494161c5ceccf078cae7eeb453916662d4523ebfec SHA512 0d2254f448ce701b8b9065720dee5301751b72367c4985b0aac4487f11c90175f7388a51a4cbd70ea78ef00727cf40c898740fd04dd920719e5e7d02bda1ab34
+EBUILD jupyter-client-8.6.1.ebuild 1569 BLAKE2B b21185681d5821a73fcf705327b13da03182ed69f0ac5a891a3a137d84ee7510dcadb0c99266c6c71690c312326a40698209ae9083e41114355195c3a32265a8 SHA512 713ec3d24607c60cddde7148bcce97dab89195fae97055da338a18f9e5385e10eeeefca8175dc11e782903bb8618402a57f9f51569525a2c6edf15a152b50729
MISC metadata.xml 844 BLAKE2B 8beea01f144f8e28b58b1bd4d0d2a32eda4b5e50e479c83ed940cd6894d581aa22418bc2733910465cb6980134c3a29b63a6e31f595d037b9492337285837ac6 SHA512 73f427cc561e728c6f941052a4b6f9c6ec5c9d6ba3bb601bc58313687dfc8d6ed3602e1fb2f7f0ea00aec4360c8c1200334675917d22092ed79585b117865ebd
diff --git a/dev-python/jupyter-client/jupyter-client-8.6.1.ebuild b/dev-python/jupyter-client/jupyter-client-8.6.1.ebuild
new file mode 100644
index 000000000000..2361f98a8227
--- /dev/null
+++ b/dev-python/jupyter-client/jupyter-client-8.6.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Jupyter protocol implementation and client libraries"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/jupyter_client/
+ https://pypi.org/project/jupyter-client/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ >=dev-python/jupyter-core-5.1[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.2[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-23.0[${PYTHON_USEDEP}]
+ >=dev-python/tornado-6.0[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib-metadata-4.8.3[${PYTHON_USEDEP}]
+ ' 3.{8,9})
+"
+BDEPEND="
+ test? (
+ >=dev-python/ipykernel-6.14[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.18[${PYTHON_USEDEP}]
+ >=dev-python/pytest-jupyter-0.4.1[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO: times out
+ tests/test_client.py::TestAsyncKernelClient::test_input_request
+ # TODO
+ tests/test_multikernelmanager.py::TestKernelManager::test_tcp_cinfo
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -o tmp_path_retention_policy=all \
+ -p asyncio -p rerunfailures --reruns=3 -p timeout
+}