summaryrefslogtreecommitdiff
path: root/dev-python/jsonpointer/jsonpointer-3.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jsonpointer/jsonpointer-3.0.0.ebuild')
-rw-r--r--dev-python/jsonpointer/jsonpointer-3.0.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/jsonpointer/jsonpointer-3.0.0.ebuild b/dev-python/jsonpointer/jsonpointer-3.0.0.ebuild
new file mode 100644
index 000000000000..b32639b244df
--- /dev/null
+++ b/dev-python/jsonpointer/jsonpointer-3.0.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Identify specific nodes in a JSON document (according to draft 08)"
+HOMEPAGE="
+ https://github.com/stefankoegl/python-json-pointer/
+ https://pypi.org/project/jsonpointer/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~x64-macos"
+
+python_test() {
+ "${EPYTHON}" tests.py || die "Tests fail with ${EPYTHON}"
+}