summaryrefslogtreecommitdiff
path: root/dev-python/jsonpointer/jsonpointer-2.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jsonpointer/jsonpointer-2.3.ebuild')
-rw-r--r--dev-python/jsonpointer/jsonpointer-2.3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/jsonpointer/jsonpointer-2.3.ebuild b/dev-python/jsonpointer/jsonpointer-2.3.ebuild
new file mode 100644
index 000000000000..6fe5363d2610
--- /dev/null
+++ b/dev-python/jsonpointer/jsonpointer-2.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Identify specific nodes in a JSON document (according to draft 08)"
+HOMEPAGE="
+ https://github.com/stefankoegl/python-json-pointer/
+ https://pypi.org/project/jsonpointer/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+python_test() {
+ "${EPYTHON}" tests.py || die "Tests fail with ${EPYTHON}"
+}