summaryrefslogtreecommitdiff
path: root/dev-python/json5/json5-0.9.20.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/json5/json5-0.9.20.ebuild')
-rw-r--r--dev-python/json5/json5-0.9.20.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/json5/json5-0.9.20.ebuild b/dev-python/json5/json5-0.9.20.ebuild
new file mode 100644
index 000000000000..ef679f5690a7
--- /dev/null
+++ b/dev-python/json5/json5-0.9.20.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Python implementation of the JSON5 data format"
+HOMEPAGE="
+ https://github.com/dpranke/pyjson5/
+ https://pypi.org/project/json5/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+distutils_enable_tests pytest