summaryrefslogtreecommitdiff
path: root/dev-python/json-rpc/json-rpc-1.11.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/json-rpc/json-rpc-1.11.0.ebuild')
-rw-r--r--dev-python/json-rpc/json-rpc-1.11.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/json-rpc/json-rpc-1.11.0.ebuild b/dev-python/json-rpc/json-rpc-1.11.0.ebuild
new file mode 100644
index 000000000000..b46a3f9f107e
--- /dev/null
+++ b/dev-python/json-rpc/json-rpc-1.11.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="JSON-RPC transport implementation for python"
+HOMEPAGE="https://github.com/pavlov99/json-rpc"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ cat > jsonrpc/six.py <<- EOF
+ from __future__ import absolute_import
+ from six import *
+ EOF
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test
+}