summaryrefslogtreecommitdiff
path: root/dev-python/js2py
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/js2py')
-rw-r--r--dev-python/js2py/Manifest2
-rw-r--r--dev-python/js2py/js2py-0.71.ebuild47
2 files changed, 0 insertions, 49 deletions
diff --git a/dev-python/js2py/Manifest b/dev-python/js2py/Manifest
index 4eb43acb3833..fa2b90ee338a 100644
--- a/dev-python/js2py/Manifest
+++ b/dev-python/js2py/Manifest
@@ -1,5 +1,3 @@
-DIST Js2Py-0.71.tar.gz 1969618 BLAKE2B 293a830f4188e66927b23900e8c376bf1a4bfdfa8726e33aa5aa75dcdf735cde89ce463741c142fc7e487ae89c7c11421e459d2fdd09ba88edfe953e4e087e42 SHA512 75bae61619d4766117f3c163d36427f3019825ecb08b745aee7c3b6f2d33a4ea8507ca180b63c0a8e575a5f9491eb64d6963acbb912edc7b934a676b38814597
DIST Js2Py-0.71_p20210918.tar.gz 1970784 BLAKE2B 4ea446b306e858c2acb192a699b4c098cca1a334fd97246d3149186795a013fa1ff9cf45ecc5cd9bed241b13b3eb003ebf272f5af4ed24a608564fd4709e4ff1 SHA512 810363e4b0716e324e6deb5f373968c9c57e7ecf120710c064601ad46ca2f24bc8da52f779f861296dd506de06d664be86b3c0d72bcb811892fe4e6c22ad7a6d
-EBUILD js2py-0.71.ebuild 1157 BLAKE2B 516469da33f8585b37dc0103bbdd0e106d97f04a0e3eb23ce1aebf7ff84886143eedd9877075880e62e9b6939246d47722d8e7c6d15f41800760182b671f98a8 SHA512 b298e699f7117c93e73fac3154eafa35794511f720ed125ba31f051e8908ccd8f404952ee3018973af30031fcc735b7091aae693add03da91a34e3a84b41d376
EBUILD js2py-0.71_p20210918.ebuild 1127 BLAKE2B 46f6387148d8a1c6c0e3678e021dd32ab1c018fe33be1966feb1a0f592ab950fc8e662f06e7bac3af3ca76e5f71203c51ccd23df29143bcd92e317d3b56e901f SHA512 48eacd37e89f85f90b041a8960549bd3d93888bd70301f559fdb840bfb94bd1ee2f5a83d2202cf54fa4f7205828f962579714397a7eac92f22643a7c5ff9caf9
MISC metadata.xml 385 BLAKE2B 145afe58273b407d1ba1f3859de0d79a3bdd4307575d043a8b574a8bac26c2d577efec841c6c3a9424ca7970dac33517df48c0f287c18bf4e1cc5faa5125ba6e SHA512 7e48c836578bcbb4abf0d99f0f2b870ab15158f05d5c402e2d84c9f9de7d2c994127eba26897e406b6c7d77c962867d39a37bf7ce78ca09d39b78d64f9d8d68d
diff --git a/dev-python/js2py/js2py-0.71.ebuild b/dev-python/js2py/js2py-0.71.ebuild
deleted file mode 100644
index 0dd24131e258..000000000000
--- a/dev-python/js2py/js2py-0.71.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MY_COMMIT="5f665f60083a9796ec33861240ce31d6d2b844b6"
-
-MY_PN="Js2Py"
-MY_P="${MY_PN}-${PV}"
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="JavaScript to Python Translator & JavaScript interpreter in Python"
-HOMEPAGE="
- http://piter.io/projects/js2py/
- https://github.com/PiotrDabkowski/Js2Py/
- https://pypi.org/project/Js2Py/
-"
-SRC_URI="https://github.com/PiotrDabkowski/${MY_PN}/archive/${MY_COMMIT}.tar.gz -> ${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc x86"
-
-RDEPEND="
- >=dev-python/pyjsparser-2.5.1[${PYTHON_USEDEP}]
- >=dev-python/tzlocal-1.2.0[${PYTHON_USEDEP}]
- >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
-"
-
-S="${WORKDIR}/${MY_PN}-${MY_COMMIT}"
-
-python_test() {
- pushd ./tests >/dev/null || die
-
- # Tests require "node_failed.txt" file where the logs are kept
- if [[ -f ./node_failed.txt ]]; then
- rm ./node_failed.txt || die
- fi
-
- touch ./node_failed.txt || die
- "${EPYTHON}" ./run.py || die "tests failed with ${EPYTHON}"
-
- popd >/dev/null || die
-}