summaryrefslogtreecommitdiff
path: root/dev-python/josepy/josepy-1.6.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/josepy/josepy-1.6.0.ebuild')
-rw-r--r--dev-python/josepy/josepy-1.6.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/josepy/josepy-1.6.0.ebuild b/dev-python/josepy/josepy-1.6.0.ebuild
new file mode 100644
index 000000000000..08704af967d5
--- /dev/null
+++ b/dev-python/josepy/josepy-1.6.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="JOSE protocol implementation in Python"
+HOMEPAGE="https://github.com/certbot/josepy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=dev-python/cryptography-0.8[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+"
+BDEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Remove coverage/flake8 options
+ sed -i '/^addopts =/d' pytest.ini || die
+ distutils-r1_python_prepare_all
+}