summaryrefslogtreecommitdiff
path: root/dev-python/joblib
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/joblib')
-rw-r--r--dev-python/joblib/Manifest4
-rw-r--r--dev-python/joblib/files/joblib-1.3.2-py3.12-avoid-ast.num-and-node.n.patch15
-rw-r--r--dev-python/joblib/files/joblib-1.3.2-py3.12-no-depr-warn.patch15
-rw-r--r--dev-python/joblib/joblib-1.3.2.ebuild60
4 files changed, 0 insertions, 94 deletions
diff --git a/dev-python/joblib/Manifest b/dev-python/joblib/Manifest
index 9d4a94a108c2..d1c36d960609 100644
--- a/dev-python/joblib/Manifest
+++ b/dev-python/joblib/Manifest
@@ -1,7 +1,3 @@
-AUX joblib-1.3.2-py3.12-avoid-ast.num-and-node.n.patch 561 BLAKE2B 7fbe05fbe4a0b6fb6b1b8f94256f3224e6c0ea8efbc9a331e6c791f35fd2ee2e211a8970120b5ab551c37af843acb7e39436255263bbaa833a41d5fdb8fa3906 SHA512 fbd84f2ff01e70f0012c3302bf9c4104411eb6eb74c0bde09051e8b903993996da8379e431a21c3f3c67a386d0ae936b5a92e0667450e9542ae59ecf356fa429
-AUX joblib-1.3.2-py3.12-no-depr-warn.patch 774 BLAKE2B f44a1dfbd8d9239230f5ae21635d303ed801e2ed92cffb1bc3d28e44d1fdc0d4c0923e7584bf79f28bd9c4a189cb29012596df2f6c3cc7e6bdd6511c80935db2 SHA512 9184c4728ddc60ffb406bcb13355f1b9b1449d152cc3064fa8a3852e3bd8cf80764f2a4d3a56bc37f34bba94bb6051b3a298631a7e4e02fe583df204cdb9cc57
-DIST joblib-1.3.2.tar.gz 1987720 BLAKE2B f16235ead3ef0172a1e0dc2abad44967b029196f6c8c7a7e0c64283cac80e2b942ebfc2df5fa975bc152f574db023a9705f48b38855a11878e5c21e04cf7d831 SHA512 9b5acba1321351cf2ae548161ced18774b8b316aaf883cc8e77bf58898d1913361a3845d64f1f1f87e4e2394eafd92e0a6a8d67947db0c9a95a40e5f579baae6
DIST joblib-1.4.0.tar.gz 2115863 BLAKE2B cd61f3523ee697382db601ebb460aa6f4cd35947978fb07473c5e2e5337713a05aee8339acee211be0076d84a00174c37623cd6010b492aee84337abc2e5e633 SHA512 5c7e5475347906cdc8575eac8d2052470408c4ed5267d59a88a9d3126fb72b977d20b24fb0983b070e2f3c101e7da000fc03231733fef62531f9aeffacc47baf
-EBUILD joblib-1.3.2.ebuild 1501 BLAKE2B bfd2269757932171aeaffa99473ab994220dc2f59f740aebb991e0dcee0b1558f87219ce5dff7a9ef14c0b176030e3ae916e3f2bd6c037e341262009f383072c SHA512 f8c98309e421190d039bc3c1bcbbab02b913f137e5a4595f51f8ca10327f7857a37eb7367320c0879b238dad2901de4a90a9ee11825100ec12e51a52af5b68d1
EBUILD joblib-1.4.0.ebuild 1376 BLAKE2B 0a5d8a305595de36aa6be1a207a10a19642d0c28204e63d54b58fd0fb34ccd7b1a0f64e1d1b3120b8926dbe2bfd0412a22979ce8f6f4957530a8628a8b5bf3ee SHA512 c61b0bff9b9ce336c92eed0a02c3efdf3c052affdd55dd06a1cadbf45773e36caaba8cfc7cf4b91542302663ee2d6d339255d5501b234c0f5ad32ba15537e612
MISC metadata.xml 858 BLAKE2B e141cefc3f64a2d853994352590d9edb2dfcf8406e64de688b5ee077e7577ec255f214134ff04cccdd90bb08410495ca0c39081b9f530763735c12214e66c871 SHA512 4938b0a8200be169056c19816c9f6753fb19e2d89a5799de9ee9e04e48d815aec84049c480a0844e391aef1647af8b3ea70186d5a6b10be1b3dbffc13711d3ba
diff --git a/dev-python/joblib/files/joblib-1.3.2-py3.12-avoid-ast.num-and-node.n.patch b/dev-python/joblib/files/joblib-1.3.2-py3.12-avoid-ast.num-and-node.n.patch
deleted file mode 100644
index a9865e00380e..000000000000
--- a/dev-python/joblib/files/joblib-1.3.2-py3.12-avoid-ast.num-and-node.n.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff --git a/joblib/_utils.py b/joblib/_utils.py
-index 7693310e0..6cd99ad31 100644
---- a/joblib/_utils.py
-+++ b/joblib/_utils.py
-@@ -35,8 +35,8 @@ def eval_expr(expr):
-
-
- def eval_(node):
-- if isinstance(node, ast.Num): # <number>
-- return node.n
-+ if isinstance(node, ast.Constant): # <constant>
-+ return node.value
- elif isinstance(node, ast.BinOp): # <left> <operator> <right>
- return operators[type(node.op)](eval_(node.left), eval_(node.right))
- elif isinstance(node, ast.UnaryOp): # <operator> <operand> e.g., -1
diff --git a/dev-python/joblib/files/joblib-1.3.2-py3.12-no-depr-warn.patch b/dev-python/joblib/files/joblib-1.3.2-py3.12-no-depr-warn.patch
deleted file mode 100644
index 4d5a28815e4a..000000000000
--- a/dev-python/joblib/files/joblib-1.3.2-py3.12-no-depr-warn.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff --git a/joblib/test/test_parallel.py b/joblib/test/test_parallel.py
-index 906d436..c4a727c 100644
---- a/joblib/test/test_parallel.py
-+++ b/joblib/test/test_parallel.py
-@@ -189,6 +189,10 @@ def test_main_thread_renamed_no_warning(backend, monkeypatch):
- # warninfo catches Warnings from worker timeouts. We remove it if it exists
- warninfo = [w for w in warninfo if "worker timeout" not in str(w.message)]
-
-+ # We don't want to count DeprecationWarnings
-+ warninfo = [w for w in warninfo
-+ if not isinstance(w.message, DeprecationWarning)]
-+
- # The multiprocessing backend will raise a warning when detecting that is
- # started from the non-main thread. Let's check that there is no false
- # positive because of the name change.
diff --git a/dev-python/joblib/joblib-1.3.2.ebuild b/dev-python/joblib/joblib-1.3.2.ebuild
deleted file mode 100644
index eacb811bfeb7..000000000000
--- a/dev-python/joblib/joblib-1.3.2.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-DISTUTILS_USE_PEP517=setuptools
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Tools to provide lightweight pipelining in Python"
-HOMEPAGE="
- https://joblib.readthedocs.io/en/latest/
- https://github.com/joblib/joblib/
- https://pypi.org/project/joblib/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc ppc64 ~riscv x86 ~arm64-macos ~x64-macos"
-
-RDEPEND="
- dev-python/cloudpickle[${PYTHON_USEDEP}]
- dev-python/loky[${PYTHON_USEDEP}]
-"
-# joblib is imported by setup.py so we need ${RDEPEND}
-BDEPEND="
- ${RDEPEND}
- test? (
- dev-python/threadpoolctl[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- # Borrowed from Fedora: https://github.com/joblib/joblib/issues/1478
- "${FILESDIR}/${P}-py3.12-no-depr-warn.patch"
- # https://github.com/joblib/joblib/pull/1518
- "${FILESDIR}/${P}-py3.12-avoid-ast.num-and-node.n.patch"
-)
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # https://github.com/joblib/joblib/issues/1115
- joblib/test/test_memory.py::test_parallel_call_cached_function_defined_in_jupyter
- # unexpectedly pickleable?
- joblib/test/test_hashing.py::test_hashing_pickling_error
-)
-
-python_prepare_all() {
- # unbundle
- rm -r joblib/externals || die
- sed -e "/joblib.externals/d" -i pyproject.toml || die
- find -name '*.py' -exec \
- sed -e 's:\(joblib\)\?\.externals\.::' \
- -e 's:from \.externals ::' \
- -i {} + || die
-
- distutils-r1_python_prepare_all
-}