summaryrefslogtreecommitdiff
path: root/dev-python/joblib/joblib-1.4.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/joblib/joblib-1.4.2.ebuild')
-rw-r--r--dev-python/joblib/joblib-1.4.2.ebuild25
1 files changed, 14 insertions, 11 deletions
diff --git a/dev-python/joblib/joblib-1.4.2.ebuild b/dev-python/joblib/joblib-1.4.2.ebuild
index aa95f7bec3b5..3cf8cc823974 100644
--- a/dev-python/joblib/joblib-1.4.2.ebuild
+++ b/dev-python/joblib/joblib-1.4.2.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1 pypi
@@ -27,21 +27,12 @@ RDEPEND="
BDEPEND="
${RDEPEND}
test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
dev-python/threadpoolctl[${PYTHON_USEDEP}]
)
"
distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # https://github.com/joblib/joblib/issues/1115
- joblib/test/test_memory.py::test_parallel_call_cached_function_defined_in_jupyter
- # unexpectedly pickleable?
- joblib/test/test_hashing.py::test_hashing_pickling_error
- # https://github.com/joblib/joblib/issu
- joblib/test/test_parallel.py::test_main_thread_renamed_no_warning
-)
-
python_prepare_all() {
# unbundle
rm -r joblib/externals || die
@@ -53,3 +44,15 @@ python_prepare_all() {
distutils-r1_python_prepare_all
}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # https://github.com/joblib/joblib/issues/1115
+ joblib/test/test_memory.py::test_parallel_call_cached_function_defined_in_jupyter
+ # https://github.com/joblib/joblib/issues/1478
+ joblib/test/test_parallel.py::test_main_thread_renamed_no_warning
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio
+}