summaryrefslogtreecommitdiff
path: root/dev-python/jmespath/jmespath-0.10.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jmespath/jmespath-0.10.0.ebuild')
-rw-r--r--dev-python/jmespath/jmespath-0.10.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/jmespath/jmespath-0.10.0.ebuild b/dev-python/jmespath/jmespath-0.10.0.ebuild
new file mode 100644
index 000000000000..c0b40b306c50
--- /dev/null
+++ b/dev-python/jmespath/jmespath-0.10.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+MY_P=jmespath.py-${PV}
+DESCRIPTION="JSON Matching Expressions"
+HOMEPAGE="https://github.com/jmespath/jmespath.py/
+ https://pypi.org/project/jmespath/"
+SRC_URI="
+ https://github.com/jmespath/jmespath.py/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests nose