summaryrefslogtreecommitdiff
path: root/dev-python/jikanpy/jikanpy-4.3.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jikanpy/jikanpy-4.3.2.ebuild')
-rw-r--r--dev-python/jikanpy/jikanpy-4.3.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/jikanpy/jikanpy-4.3.2.ebuild b/dev-python/jikanpy/jikanpy-4.3.2.ebuild
new file mode 100644
index 000000000000..7723c4ff2c19
--- /dev/null
+++ b/dev-python/jikanpy/jikanpy-4.3.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for jikan.moe API."
+HOMEPAGE="https://pypi.org/project/jikanpy/"
+SRC_URI="https://github.com/abhinavk99/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? ( dev-python/vcrpy[${PYTHON_USEDEP}] )
+"
+
+RDEPEND="
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest