summaryrefslogtreecommitdiff
path: root/dev-python/jeepney
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jeepney')
-rw-r--r--dev-python/jeepney/Manifest4
-rw-r--r--dev-python/jeepney/jeepney-0.5.0.ebuild43
-rw-r--r--dev-python/jeepney/jeepney-0.6.0.ebuild43
3 files changed, 90 insertions, 0 deletions
diff --git a/dev-python/jeepney/Manifest b/dev-python/jeepney/Manifest
index 9e8ced4a701f..b1155f452fa3 100644
--- a/dev-python/jeepney/Manifest
+++ b/dev-python/jeepney/Manifest
@@ -1,3 +1,7 @@
DIST jeepney-0.4.3.tar.gz 28121 BLAKE2B 2c9b5b5ec26a9af25d28af602827c73c8ec9377a88a4aa79b9a986675c1ef3f195763a338f3efa4ee371f7751dcf05a9f9cfed06c8d6677d81da3699773d5561 SHA512 bfb12c9259a57324759f8be44d1faf2c0535762e72db5f1370e64cb144c0fc537c9bc9cfb9b075932fb3a20e3ef4e0c990c10905cc5a69e3fb088e8de4193689
+DIST jeepney-0.5.0.tar.gz 48460 BLAKE2B 5ce1fd0315ad839cf2e0ec5616a448da840d1d3b1720528a0cd858526815b062929ebdc92916820008969092bce470c88704deb96c6120c086f631d1312985b9 SHA512 ae80a363cac4944cb6a499450835176d63e29545b8025c6dd0241a08b35e7b2564beaab578cbba319799ec5530fd6fed7e9f910e401d68b46290617e5f739992
+DIST jeepney-0.6.0.tar.gz 49513 BLAKE2B e5f9b5104cf07dbcd2d40c2d22b690dfd56c456ab56daf44f4abee83f0bfe7e1dfbad797348044d51e3dc20fbc6ce68bf8df54f9c1e46d7a86ceb22d3ab30f8d SHA512 140be9dd28ed853d2d41b6a8bbeb2f22c0270ce7bf33b943ec2ac010db17d4f06e253fa8637fbbb3044fe9ffdbfa1e15f0c663eb44bdd538f8c47c2e7dab3ca5
EBUILD jeepney-0.4.3.ebuild 802 BLAKE2B aefbece367f00496eaf9b986ee25c8b470dbac4d4ec4c9715b8b1d29b8c31f4307d6b0ce67154b9fd78bd518f984c8fd109185610a7b9dc89efef7b57568fd49 SHA512 13e500ebc659528d61478f15329c0b084c5556779e742144c5d3e5d3bff1c3c9eeaec607974c58e74c730c8893ff662223adca2fc2971f8a4672af687e339fb1
+EBUILD jeepney-0.5.0.ebuild 901 BLAKE2B 8a3f0123b780ceb28472ae42413935fc9275d3b18f7afd38bb2b6f63c42b5e917b7d649de0a9e34166879cb4d6054426570479ddfffc318f7be785019b956167 SHA512 f803c084da92b733fda5e044c6d0a055cec364e927d2f02f94e34986691c056a06e87a64ba2d1502f892e5207aa79ae36d7f23c4153763fc1e23874583efb023
+EBUILD jeepney-0.6.0.ebuild 901 BLAKE2B 8a3f0123b780ceb28472ae42413935fc9275d3b18f7afd38bb2b6f63c42b5e917b7d649de0a9e34166879cb4d6054426570479ddfffc318f7be785019b956167 SHA512 f803c084da92b733fda5e044c6d0a055cec364e927d2f02f94e34986691c056a06e87a64ba2d1502f892e5207aa79ae36d7f23c4153763fc1e23874583efb023
MISC metadata.xml 432 BLAKE2B 57cc148c4580f5dd579dfbec20c85c80e7d5f2b75397c96f4daa2382e86dbe0547b15ac628fc46bb62c3845becb46cfcfb65027f37839d2d1f843c6872d45e80 SHA512 124413d7ca2a366a651128cd8346aeeb3bd5ceed9b43136fad32861844a078694fa8603e4a11df4d7b37343434bf29bf21d0a0ac6999bf9e9b13f474b93914e4
diff --git a/dev-python/jeepney/jeepney-0.5.0.ebuild b/dev-python/jeepney/jeepney-0.5.0.ebuild
new file mode 100644
index 000000000000..1c412f4100c2
--- /dev/null
+++ b/dev-python/jeepney/jeepney-0.5.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( pypy3 python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, pure Python DBus protocol wrapper"
+HOMEPAGE="https://gitlab.com/takluyver/jeepney"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="examples"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme
+
+src_prepare() {
+ rm jeepney/io/tests/test_trio.py || die
+ distutils-r1_src_prepare
+}
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/jeepney/jeepney-0.6.0.ebuild b/dev-python/jeepney/jeepney-0.6.0.ebuild
new file mode 100644
index 000000000000..1c412f4100c2
--- /dev/null
+++ b/dev-python/jeepney/jeepney-0.6.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( pypy3 python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, pure Python DBus protocol wrapper"
+HOMEPAGE="https://gitlab.com/takluyver/jeepney"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="examples"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme
+
+src_prepare() {
+ rm jeepney/io/tests/test_trio.py || die
+ distutils-r1_src_prepare
+}
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}