summaryrefslogtreecommitdiff
path: root/dev-python/jeepney/jeepney-0.6.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jeepney/jeepney-0.6.0.ebuild')
-rw-r--r--dev-python/jeepney/jeepney-0.6.0.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-python/jeepney/jeepney-0.6.0.ebuild b/dev-python/jeepney/jeepney-0.6.0.ebuild
index ca32aa3661f1..42dd4172cf33 100644
--- a/dev-python/jeepney/jeepney-0.6.0.ebuild
+++ b/dev-python/jeepney/jeepney-0.6.0.ebuild
@@ -4,7 +4,7 @@
EAPI=7
DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( pypy3 python3_{7,8,9} )
+PYTHON_COMPAT=( pypy3 python3_{7..10} )
inherit distutils-r1
@@ -21,6 +21,7 @@ BDEPEND="
test? (
dev-python/pytest-asyncio[${PYTHON_USEDEP}]
dev-python/testpath[${PYTHON_USEDEP}]
+ sys-apps/dbus
)
"
@@ -34,6 +35,10 @@ src_prepare() {
distutils-r1_src_prepare
}
+python_test() {
+ dbus-run-session pytest -vv -ra -l || die "tests failed with ${EPYTHON}"
+}
+
python_install_all() {
if use examples; then
docompress -x "/usr/share/doc/${PF}/examples"