summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-test/jaraco-test-5.4.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jaraco-test/jaraco-test-5.4.0.ebuild')
-rw-r--r--dev-python/jaraco-test/jaraco-test-5.4.0.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/dev-python/jaraco-test/jaraco-test-5.4.0.ebuild b/dev-python/jaraco-test/jaraco-test-5.4.0.ebuild
index 185131c7284f..005487247012 100644
--- a/dev-python/jaraco-test/jaraco-test-5.4.0.ebuild
+++ b/dev-python/jaraco-test/jaraco-test-5.4.0.ebuild
@@ -6,7 +6,7 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
PYPI_PN=${PN/-/.}
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
inherit distutils-r1 pypi
@@ -28,6 +28,13 @@ RDEPEND="
distutils_enable_tests pytest
+src_test() {
+ # workaround namespaces blocking test.support import (sigh!)
+ mv jaraco/test jaraco_test || die
+ rmdir jaraco || die
+ distutils-r1_src_test
+}
+
python_test() {
# while technically these tests are skipped when Internet is
# not available (they test whether auto-skipping works), we don't