summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-collections
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jaraco-collections')
-rw-r--r--dev-python/jaraco-collections/Manifest5
-rw-r--r--dev-python/jaraco-collections/files/jaraco-collections-3.0.0-pypy.patch30
-rw-r--r--dev-python/jaraco-collections/jaraco-collections-3.3.0.ebuild6
-rw-r--r--dev-python/jaraco-collections/jaraco-collections-3.4.0.ebuild29
4 files changed, 33 insertions, 37 deletions
diff --git a/dev-python/jaraco-collections/Manifest b/dev-python/jaraco-collections/Manifest
index 1693a30a5273..5e507cc2a65b 100644
--- a/dev-python/jaraco-collections/Manifest
+++ b/dev-python/jaraco-collections/Manifest
@@ -1,4 +1,5 @@
-AUX jaraco-collections-3.0.0-pypy.patch 977 BLAKE2B 528835efbb2d7c6f60e9f49b35032649f81d5b3ae08a8dbaa6ff1e362619eb886570c14240f1660f2a8cd63f54ab4651d26a2e401c01557582fcdd9294a037fc SHA512 6bf4b43230ce7cfaa4971cf1d8bc243378284ef2381d910a9b6932f067c689ae46a3e9caec9ef696f72aaf2d0fa9f5226f79abeeba047c847926a2f588ae27f9
DIST jaraco.collections-3.3.0.tar.gz 18563 BLAKE2B 80e8463324598cdd6025984c6ab304b108521a606de87fa7aeacbb2234aec5fce20319d7cd288caa5a46b1fefb7e7686a2d00e668e90c38b943082267e6b4ceb SHA512 23fea645226bcfbd5f034877aff7846960ad99d65d451bdbf5b8abb166356074d07780ea8e2e25d31fd03343929596dcd64a9ec949c1ff056c11862e043a8b7e
-EBUILD jaraco-collections-3.3.0.ebuild 852 BLAKE2B bf0e345bfc34871757f9f21520e685a04190afccd612d1a8771c37d03511d599e88f66fc4e1f9a4118a26e8f9686959cf32f10dc1c1cc3e72392209877d64384 SHA512 18dfedf56de1c67f0f649dace6ec41c158655a603e2fe7d480691fd3fbdfdbc9e2a2570e1c89bdd55121b09b4ff8d04f2ee3b3b82573ec45fa6a1d2fc722cc0d
+DIST jaraco.collections-3.4.0.tar.gz 14887 BLAKE2B 2c1e87b18dc3ca68fb5b849b30cc0284b8a8daed9b6b2b075a753f7ccf91feb487734a38bb7fc88d29020b0b1980346109551a8bba5d0b3a7f4a491c0dcb1615 SHA512 8e427f98dbcfad3f9042d1f080b2bf8012fdaaf084e230f9b46ff078623b047c2d9dab41ed0303df5dd070abce2a25289281113a97e8ab8d819048d30b8d314a
+EBUILD jaraco-collections-3.3.0.ebuild 782 BLAKE2B 1bcaf7ea216ab85bae6852411861f6f137992b944051e0d887b63c41ba034020475cc8fdf0d6dbeb1da7c4689c133487a8d70e5f844716dfc5b594335fcd7d3b SHA512 d233f09eb2cd552d9ae89509d9fc4531a5558e280df1f28787c85df2fbd1253981d5d5c4cbf50eb644840c54da289e839679c41611ecd517e653cdd848f88796
+EBUILD jaraco-collections-3.4.0.ebuild 787 BLAKE2B ca3b9c6e234678314eb84b56c7156ed30dc320235c3abd492eb6485800074dde6c3e6602949091b0cd557df181949d6bcb0c8f83fcf4a594dcd7b79514a07741 SHA512 5076b918dff98eaa514e13203766476cebee9c6debc4bb4006f19e17447a5bdfdbb5a8485093c91773ece94f61d11cc3d89d5463fd97cb0b6b7513b7c89b9b97
MISC metadata.xml 683 BLAKE2B 39d22a937701983234b04b29b79785efcade578cfb3d94f694eeb1f5fe90e82831891aa689df78ca118e2c53d7be1ad61046a12656d430cceaaf4f72630ce827 SHA512 7493fc3e325c36c0cefeb6683a97994e5c8627d4e9bc1ec0b0fb2c595c1ff10756ecc2738fa62b991e6a7993b847d780fdaffdc609171bcf255a13b37b7ccce9
diff --git a/dev-python/jaraco-collections/files/jaraco-collections-3.0.0-pypy.patch b/dev-python/jaraco-collections/files/jaraco-collections-3.0.0-pypy.patch
deleted file mode 100644
index 63cee6cb4115..000000000000
--- a/dev-python/jaraco-collections/files/jaraco-collections-3.0.0-pypy.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-diff --git a/jaraco/collections.py b/jaraco/collections.py
-index 3ab9dc9..6a6e342 100644
---- a/jaraco/collections.py
-+++ b/jaraco/collections.py
-@@ -4,6 +4,7 @@ import collections.abc
- import itertools
- import copy
- import functools
-+import platform
-
- from jaraco.classes.properties import NonDataProperty
- import jaraco.text
-@@ -592,9 +593,14 @@ class DictStack(list, collections.abc.Mapping):
- return list(set(itertools.chain.from_iterable(c.keys() for c in self)))
-
- def __getitem__(self, key):
-- for scope in reversed(self):
-- if key in scope:
-- return scope[key]
-+ if 'PyPy' in platform.python_implementation():
-+ for scope in reversed(list(self)):
-+ if key in scope:
-+ return scope[key]
-+ else:
-+ for scope in reversed(self):
-+ if key in scope:
-+ return scope[key]
- raise KeyError(key)
-
- push = list.append
diff --git a/dev-python/jaraco-collections/jaraco-collections-3.3.0.ebuild b/dev-python/jaraco-collections/jaraco-collections-3.3.0.ebuild
index a894279bf7a3..29c60505c72e 100644
--- a/dev-python/jaraco-collections/jaraco-collections-3.3.0.ebuild
+++ b/dev-python/jaraco-collections/jaraco-collections-3.3.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..10} pypy3 )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
MY_PN="${PN/-/.}"
@@ -24,10 +24,6 @@ BDEPEND="
>=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
"
-PATCHES=(
- "${FILESDIR}/jaraco-collections-3.0.0-pypy.patch"
-)
-
distutils_enable_sphinx docs '>=dev-python/jaraco-packaging-3.2' \
'>=dev-python/rst-linker-1.9'
distutils_enable_tests pytest
diff --git a/dev-python/jaraco-collections/jaraco-collections-3.4.0.ebuild b/dev-python/jaraco-collections/jaraco-collections-3.4.0.ebuild
new file mode 100644
index 000000000000..477206eaacea
--- /dev/null
+++ b/dev-python/jaraco-collections/jaraco-collections-3.4.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Models and classes to supplement the stdlib collections module"
+HOMEPAGE="https://github.com/jaraco/jaraco.collections"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ dev-python/jaraco-classes[${PYTHON_USEDEP}]
+ dev-python/jaraco-text[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs '>=dev-python/jaraco-packaging-3.2' \
+ '>=dev-python/rst-linker-1.9'
+distutils_enable_tests pytest