summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-collections/jaraco-collections-1.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jaraco-collections/jaraco-collections-1.5.ebuild')
-rw-r--r--dev-python/jaraco-collections/jaraco-collections-1.5.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/dev-python/jaraco-collections/jaraco-collections-1.5.ebuild b/dev-python/jaraco-collections/jaraco-collections-1.5.ebuild
deleted file mode 100644
index 708280d2b630..000000000000
--- a/dev-python/jaraco-collections/jaraco-collections-1.5.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
-
-inherit distutils-r1
-
-MY_PN="${PN/-/.}"
-DESCRIPTION="Models and classes to supplement the stdlib collections module"
-HOMEPAGE="https://github.com/jaraco/jaraco.collections"
-SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc test"
-
-PDEPEND="dev-python/jaraco-text[${PYTHON_USEDEP}]"
-RDEPEND="dev-python/jaraco-classes[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/setuptools_scm-1.9[${PYTHON_USEDEP}]
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/rst-linker[${PYTHON_USEDEP}]
- )
- test? (
- ${RDEPEND}
- >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
- dev-python/pytest-runner[${PYTHON_USEDEP}]
- )
-"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-python_prepare_all() {
- if use test && ! has_version "dev-python/jaraco-text"; then
- die "Ensure dev-python/jaraco-text is installed or the" \
- "test suite will fail"
- fi
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && esetup.py build_sphinx
-}
-
-python_test() {
- PYTHONPATH=. py.test || die "tests failed with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
- distutils-r1_python_install_all
-}