summaryrefslogtreecommitdiff
path: root/dev-python/itypes/itypes-1.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/itypes/itypes-1.1.0.ebuild')
-rw-r--r--dev-python/itypes/itypes-1.1.0.ebuild17
1 files changed, 17 insertions, 0 deletions
diff --git a/dev-python/itypes/itypes-1.1.0.ebuild b/dev-python/itypes/itypes-1.1.0.ebuild
new file mode 100644
index 000000000000..4a4c46fee443
--- /dev/null
+++ b/dev-python/itypes/itypes-1.1.0.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_6 )
+inherit distutils-r1
+
+DESCRIPTION="basic immutable container types for python"
+HOMEPAGE="https://github.com/tomchristie/itypes"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"