summaryrefslogtreecommitdiff
path: root/dev-python/itypes/itypes-1.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/itypes/itypes-1.1.0.ebuild')
-rw-r--r--dev-python/itypes/itypes-1.1.0.ebuild19
1 files changed, 12 insertions, 7 deletions
diff --git a/dev-python/itypes/itypes-1.1.0.ebuild b/dev-python/itypes/itypes-1.1.0.ebuild
index 43805bb673a9..7c0e5aa22446 100644
--- a/dev-python/itypes/itypes-1.1.0.ebuild
+++ b/dev-python/itypes/itypes-1.1.0.ebuild
@@ -1,18 +1,23 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
+EAPI=8
+PYTHON_COMPAT=( python3_{8..9} )
inherit distutils-r1
DESCRIPTION="basic immutable container types for python"
-HOMEPAGE="https://github.com/PavanTatikonda/itypes"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="https://github.com/PavanTatikonda/itypes/"
+SRC_URI="
+ https://github.com/PavanTatikonda/itypes/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+distutils_enable_tests pytest
+
+python_test() {
+ epytest tests.py
+}