summaryrefslogtreecommitdiff
path: root/dev-python/itunespy/itunespy-1.6-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/itunespy/itunespy-1.6-r2.ebuild')
-rw-r--r--dev-python/itunespy/itunespy-1.6-r2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/itunespy/itunespy-1.6-r2.ebuild b/dev-python/itunespy/itunespy-1.6-r2.ebuild
new file mode 100644
index 000000000000..1e17aa89d5ea
--- /dev/null
+++ b/dev-python/itunespy/itunespy-1.6-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple library to fetch data from the iTunes Store API"
+HOMEPAGE="https://github.com/sleepyfran/itunespy/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/sleepyfran/${PN}.git"
+else
+ SRC_URI="https://github.com/sleepyfran/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="amd64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="
+ dev-python/pycountry[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+
+PATCHES=( "${FILESDIR}"/${P}-setup.cfg-description_file.patch )