summaryrefslogtreecommitdiff
path: root/dev-python/itsdangerous/itsdangerous-2.1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/itsdangerous/itsdangerous-2.1.1.ebuild')
-rw-r--r--dev-python/itsdangerous/itsdangerous-2.1.1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/itsdangerous/itsdangerous-2.1.1.ebuild b/dev-python/itsdangerous/itsdangerous-2.1.1.ebuild
new file mode 100644
index 000000000000..e9e16768e94e
--- /dev/null
+++ b/dev-python/itsdangerous/itsdangerous-2.1.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Various helpers to pass trusted data to untrusted environments and back"
+HOMEPAGE="https://pythonhosted.org/itsdangerous/ https://pypi.org/project/itsdangerous/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+BDEPEND="
+ test? ( dev-python/freezegun[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest