summaryrefslogtreecommitdiff
path: root/dev-python/ipaddr/ipaddr-2.2.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ipaddr/ipaddr-2.2.0-r1.ebuild')
-rw-r--r--dev-python/ipaddr/ipaddr-2.2.0-r1.ebuild7
1 files changed, 2 insertions, 5 deletions
diff --git a/dev-python/ipaddr/ipaddr-2.2.0-r1.ebuild b/dev-python/ipaddr/ipaddr-2.2.0-r1.ebuild
index 36a2df82a523..6405683e4f7b 100644
--- a/dev-python/ipaddr/ipaddr-2.2.0-r1.ebuild
+++ b/dev-python/ipaddr/ipaddr-2.2.0-r1.ebuild
@@ -4,8 +4,7 @@
EAPI=7
DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{7,8,9} )
-
+PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1
DESCRIPTION="Python IP address manipulation library"
@@ -17,9 +16,7 @@ SLOT="0"
KEYWORDS="amd64 arm arm64 ~ppc64 x86"
python_prepare() {
- if python_is_python3; then
- 2to3 -n -w --no-diffs *.py || die
- fi
+ 2to3 -n -w --no-diffs *.py || die
}
python_test() {