summaryrefslogtreecommitdiff
path: root/dev-python/incremental/incremental-21.3.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/incremental/incremental-21.3.0-r1.ebuild')
-rw-r--r--dev-python/incremental/incremental-21.3.0-r1.ebuild30
1 files changed, 0 insertions, 30 deletions
diff --git a/dev-python/incremental/incremental-21.3.0-r1.ebuild b/dev-python/incremental/incremental-21.3.0-r1.ebuild
deleted file mode 100644
index 314d735f88a9..000000000000
--- a/dev-python/incremental/incremental-21.3.0-r1.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Incremental is a small library that versions your Python projects"
-HOMEPAGE="https://github.com/twisted/incremental https://pypi.org/project/incremental/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/click[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]"
-BDEPEND="
- test? ( dev-python/twisted[${PYTHON_USEDEP}] )"
-
-python_test() {
- "${EPYTHON}" -m twisted.trial incremental ||
- die "Tests failed on ${EPYTHON}"
-}