summaryrefslogtreecommitdiff
path: root/dev-python/importlib_resources/importlib_resources-5.6.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/importlib_resources/importlib_resources-5.6.0.ebuild')
-rw-r--r--dev-python/importlib_resources/importlib_resources-5.6.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/importlib_resources/importlib_resources-5.6.0.ebuild b/dev-python/importlib_resources/importlib_resources-5.6.0.ebuild
new file mode 100644
index 000000000000..31f3ce7d8000
--- /dev/null
+++ b/dev-python/importlib_resources/importlib_resources-5.6.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+DISTUTILS_USE_PEP517=flit
+# This is a backport of Python 3.9's importlib.resources
+PYTHON_COMPAT=( pypy3 python3_8 )
+
+inherit distutils-r1
+
+DESCRIPTION="Read resources from Python packages"
+HOMEPAGE="https://github.com/python/importlib_resources"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/zipp-3.7.0-r1[${PYTHON_USEDEP}]
+ ' 3.8 3.9)"
+
+distutils_enable_tests unittest
+distutils_enable_sphinx docs dev-python/rst-linker dev-python/jaraco-packaging
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "importlib_resources"
+ version = "${PV}"
+ description = "Read resources from Python packages"
+ EOF
+}