summaryrefslogtreecommitdiff
path: root/dev-python/immutables/immutables-0.19.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/immutables/immutables-0.19.ebuild')
-rw-r--r--dev-python/immutables/immutables-0.19.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/immutables/immutables-0.19.ebuild b/dev-python/immutables/immutables-0.19.ebuild
deleted file mode 100644
index 7fb45800af2d..000000000000
--- a/dev-python/immutables/immutables-0.19.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 2019-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="A high-performance immutable mapping type for Python"
-HOMEPAGE="
- https://github.com/MagicStack/immutables/
- https://pypi.org/project/immutables/
-"
-SRC_URI="
- https://github.com/MagicStack/${PN}/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- sed -i -e '/mypy/d' tests/conftest.py || die
- distutils-r1_src_prepare
-
- # workaround check removed from python3.12
- # https://github.com/MagicStack/immutables/pull/103
- export CFLAGS="${CFLAGS} -DHAVE_STDARG_PROTOTYPES=1"
-}
-
-src_test() {
- local EPYTEST_IGNORE=(
- tests/test_mypy.py
- )
-
- rm -r immutables || die
- distutils-r1_src_test
-}