summaryrefslogtreecommitdiff
path: root/dev-python/immutabledict/immutabledict-4.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/immutabledict/immutabledict-4.2.0.ebuild')
-rw-r--r--dev-python/immutabledict/immutabledict-4.2.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/immutabledict/immutabledict-4.2.0.ebuild b/dev-python/immutabledict/immutabledict-4.2.0.ebuild
new file mode 100644
index 000000000000..261533aad5ed
--- /dev/null
+++ b/dev-python/immutabledict/immutabledict-4.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="An immutable wrapper around dictionaries"
+HOMEPAGE="
+ https://github.com/corenting/immutabledict/
+ https://pypi.org/project/immutabledict/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # performance test which fails occasionally under heavy load,
+ # see bug 924831
+ tests/test_immutabledict.py::TestImmutableDict::test_performance
+)