summaryrefslogtreecommitdiff
path: root/dev-python/imageio-ffmpeg/imageio-ffmpeg-0.4.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/imageio-ffmpeg/imageio-ffmpeg-0.4.8.ebuild')
-rw-r--r--dev-python/imageio-ffmpeg/imageio-ffmpeg-0.4.8.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/imageio-ffmpeg/imageio-ffmpeg-0.4.8.ebuild b/dev-python/imageio-ffmpeg/imageio-ffmpeg-0.4.8.ebuild
new file mode 100644
index 000000000000..3a3d66c19a5e
--- /dev/null
+++ b/dev-python/imageio-ffmpeg/imageio-ffmpeg-0.4.8.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="FFMPEG wrapper for Python"
+HOMEPAGE="
+ https://github.com/imageio/imageio-ffmpeg/
+ https://pypi.org/project/imageio-ffmpeg/
+"
+SRC_URI="
+ https://github.com/imageio/imageio-ffmpeg/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+PROPERTIES="test_network"
+RESTRICT="test"
+
+# ffmpeg is used as an executable during runtime
+RDEPEND="
+ media-video/ffmpeg:*
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e '/setup_requires/d' -i setup.py || die
+
+ distutils-r1_src_prepare
+}